# ERROR: Grid parameters for GRIDDESC are inconsistent with initialized values

**URL:** https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926
**Category:** SMOKE
**Created:** [February 15, 2023, 9:49pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926 "2023-02-15T21:49:30Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Elsa](https://avatars.discourse-cdn.com/v4/letter/e/838e76/32.png) [@Elsa](https://forum.cmascenter.org/u/Elsa)
#### Post date: [February 15, 2023, 9:49pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926/1 "2023-02-15T21:49:30Z")

</div>

Hi, I am trying to create my own domain over my study area in SMOKE and run the emission sectors. The domain is at 4km resolution and 50 grid cells for both x and y. I first edited the griddesc\_lambertonly\_18jan2019\_v7.txt under ge\_dat/gridding, what I edited is add the following lines at the end of the griddesc file:  
‘MyDomain’  
‘LAM\_40N97W’, -1848000., -842000., 4.D3, 4.D3, 50, 50, 1  
Then I edited the directory\_definitions.csh under home/CASE/scripts, here are the changes I made:

## Grid name

setenv REGION “MyDomain 4km”

setenv REGION\_ABBREV “4MyDomain” # affects filename labeling

setenv REGION\_IOAPI\_GRIDNAME “MyDomain” # should match GRIDDESC

After this I went to the nonpoint sector and edited the Annual\_rail\_12US1\_2017gb\_17j.csh, here are the changes I made with this file:  
setenv RUN\_MONTHS “8”

setenv EPI\_STDATE\_TIME “${BASE\_YEAR}-08-01 00:00:00.0”

setenv EPI\_ENDATE\_TIME “${BASE\_YEAR}-08-10 23:59:00.0”

setenv SRGPRO “${GE\_DAT}/gridding/surrogates/CONUS4\_2017NEI\_04mar2021/USA\_100\_NOFILL.txt”

After all of the above changes, I run the Annual\_rail\_12US1\_2017gb\_17j.csh  
./Annual\_rail\_12US1\_2017gb\_17j.csh

Then I got those errors:  
ERROR: Grid origins not compatible between SaltonSea in  
grid description file and initialized values.  
ERROR: Grid parameters for SaltonSea in  
grid description file are inconsistent with initialized values.  
Any thoughts on those errors? Thanks

---

<div class="post-metadata">

### Author: ![eyth.alison](https://avatars.discourse-cdn.com/v4/letter/e/7ab992/32.png) [@eyth.alison](https://forum.cmascenter.org/u/eyth.alison)
#### Post date: [March 7, 2023, 5:18pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926/2 "2023-03-07T17:18:03Z")

</div>

Can you please confirm the region your grid is supposed to cover?

---

<div class="post-metadata">

### Author: ![hogrefe.christian](https://avatars.discourse-cdn.com/v4/letter/h/74df32/32.png) [@hogrefe.christian](https://forum.cmascenter.org/u/hogrefe.christian)
#### Post date: [March 7, 2023, 5:34pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926/3 "2023-03-07T17:34:30Z")

</div>

Based on what I can tell, the Y origin of your intended domain is not offset by an integer multiple of 4 km from the Y origin of the 4 km gridding surrogates:

4 km gridding surrogates header:  
#GRID us4k\_1548x1332 -2952000.000000 -2772000.000000 4000.000000 4000.000000 1548 1332

Your intended domain:  
‘LAM\_40N97W’, -1848000., -842000., 4.D3, 4.D3, 50, 50, 1

x offset of intended domain relative to gridding surrogates in terms of grid cells: (2,952,000 - 1,848,000) / 4,000 = 276  
y offset of intended domain relative to gridding surrogates in terms of grid cells: (2,772,000 - 842,000) / 4,000 = **482.5**

---

<div class="post-metadata">

### Author: ![Elsa](https://avatars.discourse-cdn.com/v4/letter/e/838e76/32.png) [@Elsa](https://forum.cmascenter.org/u/Elsa)
#### Post date: [March 7, 2023, 9:16pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926/4 "2023-03-07T21:16:56Z")

</div>

> [@Elsa](#):
>
> CONUS4\_2017NEI\_04mar2021

Hi Hogrefe,

Thank you so much for your reply. My issued got resolved based on your suggestion. What I did is just change my y offset of “-842000.” to “840000.” which match the default domain boundary. Then all the error disappeared and my scripts run successfully. Thanks again!

---

<div class="post-metadata">

### Author: ![Elsa](https://avatars.discourse-cdn.com/v4/letter/e/838e76/32.png) [@Elsa](https://forum.cmascenter.org/u/Elsa)
#### Post date: [March 7, 2023, 9:19pm UTC](https://forum.cmascenter.org/t/error-grid-parameters-for-griddesc-are-inconsistent-with-initialized-values/3926/5 "2023-03-07T21:19:16Z")

</div>

Hi eyth, my interested domain is located at southern California. But my issue got resolved by the following suggestion. Still appreciate your reply!
