MCIP version 5.0 Release (August 2019)

Dear @lizadams @cjcoats @tlspero

Can I use MCIPv5.0 to process outputs of WRF4.0+? Also, can I use the output of MCIPv5.0 in CMAQ-5.2.1?

Thanks in anticipation and for your usual help.

Catalyst

@Catalyst2682

Yes, MCIPv5.0 can process output from WRFv4.0+.

With the exception of data created for fractional land use, I believe you can use output from MCIPv5.0 in CMAQv5.2.1…but I would not recommend that. The fractional land use data are processed only in the output file, LUFRAC_CRO, in MCIPv5.0, and CMAQv5.2.1 is not set up to read that file. The workaround is to use GRIDCRO2D from a run with an older version of MCIP to get the fractional land use data. I think you can substitute that GRIDCRO2D for the file created by MCIPv5.0. GRIDCRO2D is time-invariant, so you only need one time step of the data to work with your CMAQ run.

Hope this helps.

–Tanya

Dear @tlspero,

Thanks a lot for your comprehensive response. I have been using the same method you mentioned to generate dust emission from land use data. Your response really helps.

Kindly respond to my issue on MCIP5.0 giving error on the thread.

Thanks and best regards,

Catalyst

@Catalyst2682

Please see my reply in that thread.

–Tanya

What setting do we use to have MCIP output files to be daily rather than being one single file for the duration specified? I am thinking that having output files for each day of the processing period will make it easy to selectively simulate any duration of a year in CMAQ? I just wanted to be sure that once MCIP is run for a full year, I can use any part of it for simulation in CMAQ.

Why? The direct access nature of the I/O API means that there are no performance penalties for trying to access one day’s meteorology even from the middle of a three-decade-long (10957-day) file.
One of the original requirements for this project is that models should be able to run efficiently as single model-runs for whatever scenario is desired – week, month, year, …

Dear @tlspero @lizadams

When I commented out config_cmaq.csh in the MCIP script, I got this new error:

Mon Sep 2 15:20:03 CST 2019

 This program uses the EPA-AREAL/MCNC-EnvPgms/BAMS Models-3      
 I/O Applications Programming Interface, [I/O API] which is      
 built on top of the netCDF I/O library (Copyright 1993, 1996    
 University Corporation for Atmospheric Research/Unidata         
 Program) and the PVM parallel-programming library (from         
 Oak Ridge National Laboratory).                                 
 Copyright (C) 1992-2002 MCNC,                                   
 (C) 1992-2013 Carlie J. Coats, Jr.,                             
 (C) 2003-2012 Baron Advanced Meteorological Systems, LLC, and   
 (C) 2014-2016 UNC Institute for the Environment.                
 Released under the GNU LGPL  License, version 2.1.  See URL     
                                                                 
     https://www.gnu.org/licenses/old-licenses/lgpl-2.1.html     
                                                                 
 for conditions of use.                                          
                                                                 
 ioapi-3.2: $Id: init3.F90 98 2018-04-05 14:35:07Z coats $
 Version with PARMS3.EXT/PARAMETER::MXVARS3= 2048
 netCDF version 4.1.3 of Apr 30 2019 21:29:51 $
  
  
 EXECUTION_ID: mcip

==============================================================================

              US EPA COMMUNITY MULTISCALE AIR QUALITY MODEL
                METEOROLOGY-CHEMISTRY INTERFACE PROCESSOR

                       MCIP V5.0 FROZEN 07/15/2019

==============================================================================

*** SUBROUTINE: READNML
*** ERROR READING NAMELIST FILE ON UNIT 8
*** NAMELIST FILE NAME = namelist.mcip
*** NAMELIST = filenames
*** IOSTAT = 5010

 *** ERROR ABORT in subroutine READNML
 ABNORMAL TERMINATION IN READNML

Error running mcip

Kindly help me out.

Thanks a lot.

Catalyst

This looks as though there is a formatting error in your namelist (maybe a misplaced comma, maybe something else).
It may or may not (depending on the vendor) be helpful to look up your Fortran vendor’s list of run-time error numbers to see whether it tells you what kind of error. Otherwise, check (painfully) character-by-character against a known-good namelist to see if you can find what is wrong.
Or maybe change compiler-vendor – some of them take more idiosyncratic interpretation of the Fortran language-standard than do others ;-(

Dear @cjcoats,

Attached are the mcip script and the namelist file generated by the script.

Thanks

Catalyst

run_mcip_36km.csh (20.4 KB) namelist.mcip.txt (672 Bytes)

Very probably the problem is the comma at the end of line 4: your compiler-vendor is probably mis-interpreting the term value separator in the Fortran Language Standard (at section 10.10.1(4) ;-(

Dear @cjcoats

What do I do to resolve this as the namelist was created while running the mcip script and I wasn’t the one that created it?

Thanks

Catalyst

vi or emacs or your favorite text-editor :slight_smile:

I didn’t get you clearly, please.

@Catalyst2682
I will do some testing of MCIPv5.0 and see if I can reproduce your problem.
Can you tell me what compiler you are using?

Dear @lizadams,

I am using gfortran (gcc) compiler and it works fine with mcip4.5 but you know mcip4.5 has issues in processing wrf4.0+.

Thanks in anticipation. It’s been really frustrating!

Catalyst

I doubt if the problem has to be the comma at the end of line 4. There’s always comma at that place even in mcip4.5 namelist file and it works fine.

@Catalyst2682

Hello! I had the same issue. Could you try to change this line??

  • set IfGeo = “T” --> try using .TRUE.

In my case, I’m still having issues, but the log file has changed, and it seems that the script ran a little bit further. I noticed that the default is “F” (and when testing the default, I got the same error when using .TRUE.), but apparently it does not work with “T” (no idea why).
Well, since I’m new on this and still having problems, I dont know if it helps, but maybe you could try.

Please, let me know if that worked for you.

Good luck!

1 Like

Dear @thayna.gomes,

Thanks a lot. It has run successfully after making the changes you suggested. Have you been able to resolve your issue too? Let me know if I can be of help, please.

Thanks and best regards.

Catalyst

1 Like

@Catalyst2682

I’m glad that it worked!

In my case, I didn’t solve the issue so far. I’ll post it on the forum hoping to get some help.

@thayna.gomes

I’m just following up to note that this issue with the namelist and the script was resolved in another thread where it was also raised. There is a typographical error in the released script where the namelist is automatically generated. I inadvertently introduced the error into the script for MCIPv5.0 when I removed the processing for MM5 and changed the name of the namelist variable from “file_ter” to “file_geo”.

The solution is to modify your script to replace “file_ter” with “file_geo” where the namelist is generated. This has been corrected in MCIPv5.1 (released with CMAQv5.3.1).

–Tanya