ISAM emission regions not found

Using CMAQ5.3 to test run ISAM, I ran into an error “user specified ISAM region VA not found in available emission regions.”

In a previous version of ISAM (v5.0.1), emission regions (two-letter state ID, for my test case) were specified in an input netcdf file and entered via an environment variable ISAM_REGIONS. That environment variable no longer works for v5.3. The User Guide mentioned editing RegionRegistry in the name list file “EmissCtrl.” Is this correct? How do I go about editing the file to make emission regions in the netcdf recognizable to the model? Can someone provide an example? Thanks.

Jin

The ISAM control file is as follows:
TAG NAME |STR
TAG CLASSES |OZONE
REGION(S) |VA
FILENAME(S) |POINT_EGU

ENDLIST eof

Hi Jin,

assuming you have a netcdf file with a variable named VA that you want to use as region in your ISAM control file, the following should work:

  • In your run script, set an environment variable that points to your file, e.g. ‘setenv REGION_MASK /path/to/your/file’ (REGION_MASK is just an example, you can use any name you like)

  • In the EmissCtrl file, edit the “&RegionsRegistry” section as follows:

&RegionsRegistry
 RGN_NML  =   
 !          | Region Label   | File_Label  | Variable on File
                     'ALL'         ,'REGION_MASK' ,'ALL',
/

The key here is that the entry in the ‘File_Label’ column needs to match the environment variable you defined in your run script.

As documented here, this instructs CMAQ to read all variables contained in the file labeled as REGION_MASK in the run script and makes these variables available for referencing in DESID and/or ISAM. This means that you can then reference the variable “VA” as region in your isam_control.txt file

If you would like to read only specific variables from the REGION_MASK file and/or would like to use a label in DESID or ISAM that differs from name of the variable file, you can use specific values rather than the “ALL” keyword in the “Region Label” and “Variable on File” columns. For example, if your file contains the variable VA but in your isam_control.txt file you would like to refer to it as VIRGINIA, you would use the following setting:

&RegionsRegistry
 RGN_NML  =   
 !          | Region Label   | File_Label  | Variable on File
        'VIRGINIA'         ,'REGION_MASK' ,'VA',
/

In this case, even if your file REGION_MASK has variables other than VA, only the VA variable will be read in and can be referenced as VIRGINIA in DESID and/or ISAM.

Finally, if you are planning to run ISAM for ozone, please see this note on the CMAQ github page.

That has fixed the error. Thanks so much, Christian. Very helpful!

Jin