'No data starting at' error when using M3TPROC

I have an I/O-API style file with the following characteristics:

 Dimensions: 246 rows, 396 cols, 1 lays, 134 vbles
 NetCDF ID:     65536  opened as READONLY
 Starting date and time  2014032:000000 (0:00:00   Feb. 1, 2014)
 Timestep                          010000 (1:00:00 hh:mm:ss)
 Maximum current record number       672

However, when I run the ‘m3tproc’ tool on variable number 4 (which is PBLH), I get an error that the file does not have data at the starting time:

What could be causing this? I am just trying to average ‘PBLH’ variable for the entire duration in the file.

671-hour aggregation-window for computing sliding averages ?? from a 24-hour-long file?

I was trying to average for all timestamps in the file that starts on 2014032:000000 and ends on 2014059:230000 with 10000 HHMMSS as timestep. To be clear with the terms used in the prompts, are you suggesting that
time window = 2014032:000000 to 2014059:230000
analysis-window = 2014032:000000 to 2014032:230000 (and not to 2014059:230000)?

I just had this warning when I tried to replace 6710000 with 240000 in the prompts when asked for analysis window duration:

You need to remove the previous “bad” file first…

I realized that my previous file was there, but removing it has not worked though!

which goes on till the end:

Maybe if see a sample batch code snippet or example script using M3TRPOC for time-averaging an I/O API file variable, I could figure out where I made a mistake in the above screenshot!