Segmentation fault in MOVESMRG

I am using smoke 4.8. When I ran the rateperdistance script(RPD), I received a Segmentation fault. Also, I did something to find out which line of MOVESMRG caused this problem.
The problem occurred in calling a subroutine named INITSTCY.

C.........  Initialize state/county summed emissions to zero

I should say that I did not receive any errors in my log file and just movemrg.log is half-written.
This is my output in the terminal.

terminal_output.txt (12.4 KB)

Could anyone help me?

When I comment a line in subroutine INITSTCY, the program runs correctly.!!!

C.........  Source totals...
        MEBSUM = 0.

Does no one have any idea?
it was so strange because I did not have this error before.

It is hard to tell with segmentation faults, but it is interesting that you commented out one line of code and that fixed it. If you can examine the Movesmrg logs - both the partially completed log with the original code, and the full log after the code change these might provide some clues. If needed, you can provide the logs.