Bioseason utility / m3tshift / tlasthour not created

I am trying to create a bioseason file for 2016 with a ten day spin up from 2015. The files created are as follows:
image

I would expect the ncf_full file to be larger than the ncf file for 2016, but the ncf_full file loses the last day of the year and the spin up days are not appended to the beginning. As you can see, the ncf_full file is smaller size than the ncf file.

I have the proper METCRO2D files for spin up and 2016 but do not have any for 2017. Do I need the first day of 2017 for it to work properly? Or is there something wrong/missing from my runscript?

Attached are the runscript and the screen output.

Thanks.
run_bioseason.txt (6.2 KB)
screen_output.txt (2.3 MB)

Yes, the final _full file should include both the 10-day spinup and the first day of the following year. So it should have 377 days: 12/22/15 through 1/1/17. Including 1/1/17 is necessary or else SMOKE will crash on 12/31/16.

There is an error in the standard output which suggests something is not working quite right:

Enter logical name for INPUT FILE [INFILE] >> INFILE :/data1/regrid/utilities/bioseason/bak/tlasthour

—>> WARNING in subroutine OPEN3

File not available.

This part of the step copies 12/31/16 to 1/1/17 so that it can be appended to the end of the file. Prior to this part of the process, the m3tshift utility is supposed to be run. This is at line 248 of the run_bioseason script:

m3tshift << EOF

$jday

0

${nextyear}001

0

240000

240000

EOF

But, we don’t see m3tshift mentioned in the standard output, and the file that is supposed to be generated by m3tshift, the “tlasthour” file, is missing. So, it looks like m3tshift isn’t being run. Do you have that utility? If you do, maybe they can figure out why that section of the run_bioseason script isn’t being executed.

Yes, I have the m3tshift utility in the /data1/v2/ioapi directory.
Thanks.

So do you see why it didn’t run?

Yes, the run script did not precede m3tshift with $IOAPI_LOCATION. I have added that so now m3tshift is found and runs. However, the ncf_full is still smaller than the ncf file and there are errors with m3tshift.

This is the output to screen:
screen_output.txt (2.3 MB)

This error says it is looking for 1/1/17 in the INFILE (the BIOSEASON which covers 1/1/16-12/31/16)…

Error reading netCDF time step flag for INFILE

M3WARN: DTBUF 0:00:00 Jan. 1, 2017 (2017001:000000)

but it should only be reading 12/31/16 from the BIOSEASON/INFILE:

Enter starting (source) date (YYYYDDD) for run [2016001] >> Using response 2016366

Enter starting (source) time (HHMMSS) for run [0] >> Using response 0

Are you using the pre-compiled m3tshift from the EPA SMOKE FTP site or your own?

Can you try running m3tshift manually? Take the bioseason that comes out, and run m3tshift in the same way that the script does (extract 12/31/16 and output with a timestamp of 1/1/17). If you get the same error, try again with 12/30/16 (2016365) instead of 12/31/16.