Error in CMAQv5.3.1 CCTM

Hi, all
I got a problem from CMAQv5.3.1 CCTM program.
I used cb6r3_ae7_aq mechanism. And I used mcipv5.1 program for using meteorology data.
But I got this problem when I ran CCTM program.

 *** ERROR ABORT in subroutine AQCHEM on PE 020
 Maximum AQCHEM total iterations exceeded

PM3EXIT: DTBUF 3:06:00 Dec. 21, 2015
Date and time 3:06:00 Dec. 21, 2015 (2015355:030600)

This means ‘ICNTAQ’ in aqchem.F is over than maximum number of loop!
I think my emission file and boundary&initial condition file was created by cb05_tucl_ae6 mechanism.
If my thinking is wrong, how to solve this???

I attached my CTM.LOG file!

Thanks :slight_smile:CTM_LOG_020.v531_pgi_cb6r3_ae7_aq_20151221.txt (94.6 KB)

You are getting warnings the default emissions control file does not contain the emission surrogates used in your emissions.

 NOTE: Some Emissions Surrogates are unused by your current
 emission control configuration. You may want to include these
 emissions if they are relevant to your application.

Please review this section of the documentation:


And also review the DESID tutorial. If you haven’t run the benchmark case, you might try running that case to learn how the Emission Control namelist is used to perform basic manipulation of your emission streams.

The following note is in the emissions control file.
!> DEFAULT MAPPING <!
! Note: Without default mapping for a species,
! there is no emission of that species.

Hi lizadams!
Thank you for your replying :slight_smile:
I will try review documentation and run benchmark case on your advice!!

I’m really grateful to you :slight_smile:

HyeonYeong Park

1 Like

The root cause is not AQCHEM. From your log file:

     After     INITSCEN :  Gas  4.242E-01  | Aer  9.471E+01  | Non  2.637E-03

This shows the sum of species concentrations for gas-phase, aerosols, and nonreactives, respectively, after reading in the initial conditions. The first science process is VDIFF, which includes emissions. After this process, your log file says:

     After        VDIFF :  Gas  4.205E-01  | Aer        NaN  | Non  2.650E-03

This indicates aerosols already contains NaN, or Not a Number.

Check to be sure there are no errors (missing data, NaNs, or infinity values) in your emissions file.

Also, I notice that your emissions file has 7 layers. That ought to work, but most of our testing with gridded emissions files over the past few years has involved files that have only one layer. You might try using the IOAPI tool M3XTRACT to extract layer 1 from the file, and rerun. If that solves the problem, let us know, since this would indicate there is a bug that should be fixed.
This thread may also be helpful.

Hi, cgnolte !
Thank you for your replying on my question :slight_smile:
I solved this problem through unchecking emission check option. So I should modify that some time after :joy:
And I have an another question to you. I’ve already posted cmas forum about that problem, I want to make time-independent ICON regrid file. But I’m using CONC file with non-zero time step for making ICON file. How can I make time-independent ICON regrid file using CONC file with non-zero time step???

I am copying Carlie Coat’s answer to this question from your other issue: Making time-independent ICON regrid file using CMAQv5.3.1

You need to use M3Tools program m3tshift with an output time-step of 0. See https://cjcoats.github.io/ioapi/M3TSHIFT.html