Error when compile create_omi

Hi everybody
I tried to compile create_omi on my laptop (Ubuntu 16.04 x64) but I got the following error message:

/home/hdong/CMAQv5.3/lib/x86_64/gcc/ioapi/lib/libioapi.a(m3msg2.o): In function m3msg2_ ': m3msg2.F :(. text + 0x1e): undefined reference to GOMP_critical_name_start ’

Although I have successfully compiled and run other programs such as icon, bcon, mcip, jproc.
Specific of this error in the attached file.

Please show me another way to fix this error.
I appreciate the help of everyone.
build_create_omi.txt (7.0 KB)
make.log.txt (14.6 KB)

You need to add -fopenmp to your compile- and link-flags.

Thanks a lot.
I added -fopenmp to FSTD and F_FLAGS, when the compilation still got the same error but when your suggestion was successful, the compilation was successful.

Hi, I also met an error when I compiled create_omi as follow:

ifort -c -fixed -132 -O0 -g -check bounds -check uninit -fpe0 -fno-alias -ftrapuv -traceback -I /home/cmaq/wfy/ku/ioapi-3.2/Linux2_x86_64ifort_openmpi -I /home/cmaq/wfy/ku/netcdf/include -I . get_env_vars.F
ifort -c -fixed -132 -O0 -g -check bounds -check uninit -fpe0 -fno-alias -ftrapuv -traceback -I /home/cmaq/wfy/ku/ioapi-3.2/Linux2_x86_64ifort_openmpi -I /home/cmaq/wfy/ku/netcdf/include -I . module_envvar.F
ifort -c -fixed -132 -O0 -g -check bounds -check uninit -fpe0 -fno-alias -ftrapuv -traceback -I /home/cmaq/wfy/ku/ioapi-3.2/Linux2_x86_64ifort_openmpi -I /home/cmaq/wfy/ku/netcdf/include -I . module_utilities.f
module_utilities.f(37): error #6378: SUBROUTINE must be present on the end-subroutine-stmt of an internal or module subroutine
compilation aborted for module_utilities.f (code 1)
make: *** [module_utilities.o] Error 1

Could you help me. Thank you
Makefile.txt (3.3 KB)

This is a Fortran syntax error in module_utilities.f (that evidently some compilers/compiler-versions let you get away with):
Every SUBROUTINE statement in a MODULE must be matched by an END SUBROUTINE, not just an END.

In particular, SUBROUTINE GET_OMI_LISTSIZE at line 8 needs an END SUBROUTINE at line 37, not just an END.

1 Like

It worked! Thank you very much.