Install_EMF Permissions

I ran the install file as an administrator. When I tried to run EMFClient.bat, I got this error:

Looking in the Tomcat 8.5 logs, I see this error:09-Jun-2020 03:57:58.432 SEVERE [localhost-startStop-1] org.apache.catalina.startup.ContextConfig.beforeStart Exception fixing docBase for context [/emf] C:\Program Files\Apache Software Foundation\Tomcat 8.5\webapps\emf.war (Access is denied)

Following troubleshooting, the Tomcat 8.5\webapps folder does not contain the emf folder. The emf.war file is there. I checked properties and it showed Blocked. I unblocked the file and ran Install_EMF again, as an administrator. Got the same error, and emf.war was Blocked again.

What can I do next?


Running the Install_EMF.bat script will copy emf.war into the Tomcat webapps directory, overwriting the permissions. I’d suggest unblocking the emf.war file like you did, then stop and restart the Tomcat process to see if it can deploy the emf.war (the step where it creates the webapps\emf folder). Usually Tomcat adds a Monitor Service item to the Windows taskbar. Right clicking should give you options to stop the service and then start it back up again.


Thanks, That worked. I also had to unblock postgresql-9.4-1201.jdbc41.jar.