Multiple Library Errors with extractEPIC2CMAQ.exe

Hello all,

I am trying to run the Spatial Allocator with FEST-C output for both data analysis and CMAQ input. I have done most of my work with version 4.3.2, but I just confirmed that I have the same first issue here with 4.4. When running ./extractEPIC2CMAQ.exe, I get many errors for shared libraries that are not found. Here’s an example error:

extractEPIC2CMAQ.exe: error while loading shared libraries: cannot open shared object file: No such file or directory

This same error occurs for also,,,,,,,,,

I tried symlinking all of the existing libraries in these folders so it could at least find the libraries. However, this is a very tedious process, and in the end, I get this error: Spatial-Allocator/src/libs/gdal-2.0.2/local/lib/ undefined symbol: _ZNK11xercesc_3_113XMLAttDefList14isSerializableEv

I have tried to recompile using the Makefile in src/raster. However, this also results in an error signalling that netcdf may need to be recompiled:

/usr/bin/ld: /home/gap6/rdf/dsc1/gap6/Spatial-Allocator/src/libs/netcdf-4.0.1/local/lib/libnetcdf.a(attr.o): relocation R_X86_64_32 against `.rodata' can not be used when making a PIE object; recompile with -fPIE
/usr/bin/ld: failed to set dynamic section sizes: bad value

I don’t notice any makefiles or instructions here. Ideally, I would not want to recompile every library from source, but any guidance here is appreciated. If I git clone the most recent version of SA and ./extractEPIC2CMAQ.exe, I have the same issue.

EDIT: I re-did my symlinking on another server and the exe runs now. However, I feel like this isn’t intended (and takes a lot of trial and error of model runs and symlinking). Also, the 12US1 domain run initially made me run out of memory (the code appears to allocate about 28gb, for anyone running this in the future.)


1 Like