Tmpbeis3 error with NEI 2015 biogenics

Using NEI Platform 2015 and smoke 4.5(precompiled with platform)

I am trying to run the biogenics sector.
I ran the beis script and this error is shown in the output:

ERROR: At least one message’s priority is less than or equal to the exit priority: 1
ERROR: Level 1 errors or Level 0 warnings found. Check log files, fix inputs, and rerun.

The log file showed the error and I am not sure how to address this issue.

ERROR: Grid type, cell sizes, or grid projection for GRID_CRO_2D      in
          gridded file are inconsistent with initialized values....

*** ERROR ABORT in subroutine HRBEIS
     TAIR=      0.00 out of range at (C,R)= 64,242
     Date and time  0:00:00   Feb. 1, 2015    (2015032:000000)

Annual_beis_12US2_2015fd_cb6_15j.csh (6.2 KB)
zbeis_25830550.txt (7.6 KB)
tmpbeis3_beis_2015fd_cb6_15j_20150201_12US2.txt (9.7 KB)

It appears the grid for your meteorological data is not the same as the grid you are trying to run your scenario for – as is mentioned by the ERROR statement.

Thank you for the clarification, I am still unsure on how to move forward.
Do I need to rerun the MCIP metgrid files or go back to the initial or producing the wrfout file for MCIP or make changes in the NEI runs?
I appreciate any insight on where I should start.

Were you trying to use EPA-provided MCIP data or your own?

What grid are you trying to use for your model run and what grid have you run MCIP for?

I am trying to run my own.

I produced the using namelist.wps and the wrfout using namelist.input before running mcip using run_mcip_mar.csh.

namelist.wps.txt (749 Bytes)
namelist.input.txt (3.6 KB)
run_mcip_mar.csh (20.1 KB)

I specified in the run_mcip_mar.csh:

set IOFORM = 1

set NCOLS =  396
set NROWS = 246

However, the outputs all had (.nc) extensions even though I set IOFORM = 1 (1 = Models-3 I/O API). I had to remove all the extensions before trying to run beis.

Also when I ncdump the METCRO2D file and some other outputs, I noticed that even though I specified it to be 396 and 246 above in the script as well as in the namelist files for WRF and WPS, the cols and rows for the METCRO2D files were:

:NCOLS = 393 ;
:NROWS = 243 ;

ncdumpMETCRO2D.txt (16.0 KB)

I had to remove all the extensions before trying to run beis.

Perhaps you need to read the i/O API manual’s section on logical names:
or even the Tutorial:

1 Like

We think you are trying to use 12US2? Did you use the EPA 12US WRF setup?

If so, and you want to use 12US2 on the same WRF projection, please use the following for creating MCIP for the grid definitions:

set BTRIM = -1

set X0 = 18

set Y0 = 15

set NCOLS = 396

set NROWS = 246

1 Like

I looked more closely at your WPS namelist. If you’re trying to use emissions information on the 12US2 EPA domain, your WRF domain isn’t large enough. I can provide a WPS namelist and MCIP grid defintions that will help, if you would like.

1 Like

I am trying to use 12US2.

When I run with those grid definitions, I get:

 ***   Requested MCIP X domain exceeds met domain
 ***   METCOL, METROW =  396   246
 ***   MCIP domain (col, row) =  399   249

     *** ERROR ABORT in subroutine SETGRIDDEFS
     Date and time  0:00:00   Feb. 1, 2015    (2015032:000000)