Tshift issue about concentration file

I try to timeshift the combine concentration files, but I get an error.

>>--->> WARNING in subroutine M3TSHIFT
     Read failure:  file  INFILE
     M3WARN:  DTBUF 12:00:00  Aug. 29, 2020 (2020242:120000)
     >>--->> WARNING in subroutine RDTFLAG
     Time step not available in file INFILE           for variable precip
     M3WARN:  DTBUF 13:00:00  Aug. 29, 2020 (2020242:130000)


I noticed some empty values in my file, is it because of this? How can I fix this?

These gaps are caused by some variable not having been written to the file (the timeste-flags are subscripted by both variable and time-step).

Is the variable precip (with that spelling, all in lower-case) actually in the file (what does ncdump -h say?)?

To fix it, you need to do a “good” re-run of whatever created INFILE.

This variable appears to be taken from the MET_CRO_2D file.

In my MET file, because there is no precip variable, I commented it out in the spec file to combine. But it seems that the merged file still has this variable, it’s just a null value. What should I do?

It seems that just commenting out (I used “!”) in spec_def_files is not an option. I deleted the precip variable completely and the combine file doesn’t seem to have nulls anymore. thank you~

Commenting out a variable definition in your combine SpecDef file with a “!” should have the same effect as deleting the line altogether.

My guess is that after you had the failed combine run which crashed because ‘precip’ couldn’t be computed from your input files, you commented out the ‘precip’ definition and reran combine successfully but did not delete the output file initially created by the crashed run. Therefore, the ‘precip’ variable was still one of the variables defined in that output file (without any actual values) because combine opens output files in ‘FSUNKN3’ mode, and the new run with the commented-out ‘precip’ line of course did not fill in any values for ‘precip’, either.
On the other hand, when you did your final run with the deleted ‘precip’ line, you probably deleted the existing output file so everything now worked fine.

It is true, you are too professional.