Unable to run pre-compiled executables

I am trying to install SMOKEv4.5, and when I run the precompiled executables I get the message:
“Please verify that both the operating system and the processor support Intel® SSE4_1, SSE4_2 and POPCNT instructions.”

Does this mean I will need to compile the smoke executables? Or is it possible there is a different problem?

I am testing by going into the executables directory and running them with no variable input (which works for other SMOKE distributions). The older versions of SMOKE on this server work fine, but the old precompiled executables were downloaded as “PG” instead of “IFORT”. When I go to download Portland Group precompiled executables for SMOKE 4.5, the link still points to IFORT. Not sure if that is the problem.

The server is running CentOS 6.10 with x86_64 architecture and Intel Xeon CPU.

Thank you

Hi Farren, since SMOKE version 3.7, I have been releasing the SMOKE precompiled executables with intel compiler although there is an option for a different compiler like PG. Yes, unfortunately, you need to compile the SMOKE on your server. Since SMOKEv4.5, our UNC cluster Linux OS have been updated and the precompiled executables won’t run on older Linux OS.
Here is recent bug ticket related to this issue.

Hello, this is a big issue that no matter what you choose, you just get precompiled executables with intel compiler. I think this should be described in the documentation after version 3.7 or in the download page, not just discuss here…

Please give us a description of the system you’re running on. Or are you running in a virtual machine?

Basically any processor of the Nehalem or later generations (i.e., post-2008) will support SSE4_1, SSE4_2 and POPCNT. (I seem to recall that the Intel compiler defaults changed at some point from 2000-vintage Prescott to 2008-vintage Nehalem instruction sets.)

If you are running in a VM, you need to install it in such a way that it emulates something other than an ancient processor…

No, I run smoke in a Linux machine:
“Linux master 2.6.32-754.17.1.el6.x86_64 #1 SMP Tue Jul 2 12:42:48 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux”
and the os is “CentOS release 6.10 (Final)”

I use pgi not intel compiler.
actually I want to stress is that
the code obtained from the downloading page is always intel-precompiled code no matter what you choose(pgi, solar or other else…)
I think this is important because I spend a lot of time to confirm what I have downloaded by accessing all of the version and compiler version…

thank you very much

What processor(s)? [e.g., what does cat /proc/cpuinfo show?