VERDI 2.1.1, Linux, GNU compiler: Yellow Screen only on launch executable (SLF4J binding messages)

SLF4J: No SLF4J providers were found.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
SLF4J: Class path contains SLF4J bindings targeting slf4j-api versions prior to 1.8.
SLF4J: Ignoring binding found at [jar:file:/e01/opt/VERDI_2.1.1/plugins/core/lib/netcdfAll-4.5.5-SNAPSHOT.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See for an explanation.

looks like verdi 2.1.1 was shipped with Java version 15.0.1, rather than 16.0.2 like it says in the user manual

For the Linux Version, it does appear that the java release is 15.0.1.
cd [install_path]/VERDI_2.1.1/jre/bin
./java --version
openjdk 15.0.1 2020-10-20
OpenJDK Runtime Environment (build 15.0.1+9-18)
OpenJDK 64-Bit Server VM (build 15.0.1+9-18, mixed mode, sharing)

Were you able to get VERDI to run on linux? The SLF4J messages are expected.

For MacOS, the install version is 16.0.2
./java --version
^[[O^[[I^[[O^[[Iopenjdk 16.0.2 2021-07-20
OpenJDK Runtime Environment Temurin-16.0.2+7 (build 16.0.2+7)
OpenJDK 64-Bit Server VM Temurin-16.0.2+7 (build 16.0.2+7, mixed mode)

For WindowsOS, the install version is
openjdk version “16” 2021-03-16
OpenJDK Runtime Environment (build 16+36-2231)
OpenJDK 64-Bit Server VM (build 16+36-2231, mixed mode, sharing)

Thanks for alerting us to the discrepancy for the linux build.

I am unable to reproduce the bug described in the title, of a yellow screen only on launch.
These are the steps I took:

  1. Start VERDI

  2. Load Dataset
    Click on yellow + under Datasets

  3. Select Variable
    Double Click on O3

  4. Create Tile Plot
    Click on Tile Plot

It results in the following screenshot.

If you are running VERDI on a remote linux server, then you need to be sure you have an X terminal set up on your local machine. For Macs, you can use Xquartz, and then use an xhost command to allow connection to your server. You can specify a specific IP address, if you do not want to allow “any host” to connect.

xhosts +
access control disabled, clients can connect from any host

Hi Liz. Thank you for getting back to me. I’m connected to the Linux server via Remote Desktop Connection, so I’m actually running it on the Linux server.
Here is a screenshot of what I see when I take step #1.

  1. Start VERDI

Hi Margaret,

We would like to duplicate your environment so we can try and reproduce this bug.
Can you tell us if you are using Xrdp or a different sever on Linux to provide the remote desktop implementation and if you are using Remote Desktop on Windows or something else to access it?

Thank you,

I am using XRDP on Linux and Remote Desktop on Windows

Hi Liz. Looking for an update on my ticket. Was going to install Verdi 2.1.3, but thinking not effective use of my time if the issue not yet resolved.
Thanks. Margaret