WRF-CMAQ error in two day test-data run

Hi, I successfully compiled WRF-CMAQ and tried running the model with two-day reference input, but I am getting the “BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES” and “CGRID file was not written” errors while trying to run “run_cctm_Bench_2018_12NE3.WRFCMAQ.csh”

I am new and couldn’t figure out the problem, I hope you can help me. thanks in advance.

rsl.out.0000.txt (47.9 KB)
2018_12NE3.log.txt (142.9 KB)
namelist.input.txt (6.9 KB)

Hi tepea,

Please provide all the rsl.* files and put them in a tarball. Thanks


Hi David,

Thank you for your quick reply, I couldn’t upload my files as a tarball. You can find the gdrive link below. I hope it will work for you.



Hi tepea,

Thanks for the tarball. Unfortunately those rsl files do not provide any additional information. Please do the following:

  -- vi configure.wrf, for FCOPTIM line, add -traceback if you are using ifort, -fbacktrace if you are using gcc
  -- delete *.o and *.mod files in phys, dyn_em, and cmaq sub-directories
  -- compile em_real >& mylog
  -- submit your job

When it crashes again, please send me all the rsl files. Thanks.


Hi David, When i try to directly compile em_real, i got some errors
mylog_direct.txt (617.7 KB)

But when i use bldit_cctm.csh with twoway option its ok.
cctm_wrfcmaq_log.txt (142.5 KB)
mylog_twoway.txt (1.0 MB



Hi tepea,

Thanks for doing that.

The reason it failed when you did it directly was these environmental variables are missing:

setenv WRF_CMAQ 1
setenv IOAPI your_ioapi_library_path

In fact, you can put these in your .cshrc or .bashrc so you won’t miss next time.

You new rsl files unfortunately (again) do not shed light on your problem. The next step is I would like to guide you to debug this issue offline. Once we have solved the problem, we can share the solution with the community. By the way, which mpi are you using?

My email address is wong.david-c@epa.gov. Thanks.