Afdust_adj dates

I am running Annual_afdust_adj_4UDAQ_2017gb_17j.csh from the 2017 platform. I have already run Annual_afdust_4UDAQ_2017gb_17j.csh without errors. My episode (with spinup) goes from June 5 to July 31 2017. I only have MCIP files for these dates. The apply.precip script errors and crashes because it appears to be searching for a June 01 2017 MCIP file (does not exist). Is there a way I can force the script to run only for my episode length? Do I need to update my smk_merge_dates txt files to include only days in my episode?

setenv RUN_MONTHS “7”
setenv SPINUP_DURATION “16”
setenv BASE_YEAR “2017”
setenv EPI_STDATE_TIME “$BASE_YEAR-07-01 00:00:00.0”
setenv EPI_ENDATE_TIME “$BASE_YEAR-07-31 23:59:00.0”

setenv L_TYPE “all”
setenv M_TYPE “all”

(SMOKE 4.7)

This can be done for onroad with the run settings file. For example, to skip the first 20 days of June 2016:

onroad, 12US1, movesmrg, PART4, 06/01/2016, 06/20/2016, N

Other sectors besides onroad work much the same way, except the run settings would say “smkmerge” instead of “movesmrg”.

I didn’t fill in the sector as afdust here because I wasn’t sure if it should be afdust_adj or not, but I think you can work that out.

1 Like

Thanks! I gave this a try and am still receiving the same error message: *** ERROR ABORT in subroutine APPLY_PRECIP_ADJ Could not open file “METCRO2D” for reading
It’s still seeking “METCRO2D_170601”

Before testing with the updated run_settings file, I cleared all the data in my afdust intermed folder. Then I ran afdust, followed by afdust_adj. Here are the lines I added to run_settings:

Sector, Grid, Environment Variable Name, Part, Start Date, End Date, Value
afdust_adj,4UDAQ,smkmerge,PART4,06/01/2017,06/14/2017,N
afdust,4UDAQ,smkmerge,PART4,06/01/2017,06/14/2017,N

It seems the afdust adjustments job uses different scripts, so use of the run settings file isn’t supported for that particular script. Instead, at the bottom of the script that runs the afdust adjustments (Annual_afdust_adj_12US1_…), change:

$RUNSCRIPTS/emf/afdust_adj_emf.csh $REGION_ABBREV -m “$RUN_MONTHS” $SPINUP_DURATION

to:

$RUNSCRIPTS/emf/afdust_adj_emf_customdates.csh $REGION_ABBREV -m “$RUN_MONTHS” $SPINUP_DURATION

That should automatically skip any day where there is not a METCRO2D.

1 Like

Hi -
I am getting an afdust_adju related error in my mrggrid run:

"AFDUST_ADJ" opened as OLD:READ-ONLY
     File name "/uufs/chpc.utah.edu/common/home/daq-group2/SMOKE4_7/2017gb_17j/premerged/mrggrid/emis_mole_afdust_adj_20170731_4UDAQ_cmaq_cb6ae7_2017gb_17j.1.tmp.ncf"
     File type GRDDED3
     Execution ID "????????????????"
     Grid name "4UDAQ"
     Dimensions: 180 rows, 186 cols, 1 lays, 19 vbles
     NetCDF ID:    524288  opened as READONLY
     Starting date and time  2017205:000000 (0:00:00   July 24, 2017)
     Timestep                          010000 (1:00:00 hh:mm:ss)
     Maximum current record number        25
     Value for ADJ_FACS not defined; returning defaultval ':  ' '
     Value for ADJ_FACS not defined; returning defaultval ':  ' '
     NOTE : No adjustment factors were applied because there is no ADJ_FACS environment variable defined
     Value for TAG_SPECIES not defined; returning defaultval ':  ' '
     Value for TAG_SPECIES not defined; returning defaultval ':  ' '
     NOTE : No tagging species were available because there is no TAG_SPECIES environment variable defined
     NOTE: Grid settings initialized using FILE001          in
          gridded file.
     ERROR: Number of time steps       24 in file
          ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
          is insufficient to cover the requested number of output
          time steps       25

     *** ERROR ABORT in subroutine SETOUTDATE
     Problem with duration of input files

However, when I check the input file here: $CASE/premerged/afdust_adj/emis_mole_afdust_adj_20170731_4UDAQ_cmaq_cb6ae7_2017gb_17j.ncf
The file has 25 timesteps and appears normally in VERDI.

netcdf emis_mole_afdust_adj_20170731_4UDAQ_cmaq_cb6ae7_2017gb_17j {
dimensions:
        TSTEP = UNLIMITED ; // (25 currently)
        DATE-TIME = 2 ;
        LAY = 1 ;
        VAR = 19 ;
        ROW = 180 ;
        COL = 186 ;

This is the last day in my modeling episode.

I tried running the sector merge again without the afdust_adj sector. Now I am getting the same timestep error for the rail sector. So this must be unrelated to my dust files!