AMET: M3WARN: Could not read input models and creating -999 (blank cells) for modeled concentration

I have used combine.exe (AMET v1.4) to create a file from CAMx2IOAPI output files. Please see the combine (script & spec_def file spec_def.camxv7.elements.txt (1.1 KB) ARDEQ_combine.ADEQ_AR_2020.txt (993 Bytes) ).

I have setup a databse ‘ AMET’ and the ran ‘aqProject_post_only_julyARDEQ’ file which was successful (attached aqProject_post_only_julyARDEQ.txt (7.1 KB) ), the terminal log of this successful run is attached (attached last some lines of log file terminal.log.txt (176.5 KB) : .
*In the terminal log, you can see there are multiple lines saying ‘Warning in subroutine , Requested variable not available”. M3WARN: DTBUF

Then I checked the files ‘ sitex_IMPROVE_ARDEQ_JUL_TRIAL’ sitex_IMPROVE_ARDEQ_JUL_TRIAL.txt (4.4 KB) ‘IMPROVE_ARDEQ_JUL_TRIAL.csv’ [attached IMPROVE_ARDEQ_JUL_TRIAL.csv (1.2 MB) ] where I can see ‘-999’ for all species of modeled data. Does it mean, this file did not record the modeled data?
4. Then I ran run_scatterplot.csh from script_analysis/aqExample folder (attached) and I got the error : “Non-numeric argument to mathematical function” (attached scatterplot.log).run_scatterplot.txt (5.3 KB) scatterplot.log.txt (1.8 KB)

I tried to fix it by following instructions from this link : AMET could not read model output - #14 by qluo

But couldn’t find out the issue.

Please help.

Thanks in advance


To answer your question, yes, there appears to be an error reading the model data. Those values should not be -999. So, this is probably due to problems in the CAMx2IOAPI conversion. You should double check that your variable names in your converted file match what AMET is looking for. Likely the CAMX species names are different from the CMAQ species names, which is why they cannot be found.

If you confirm that’s the case, you’ll need to either change the species names in your converted IOAPI file or modify the model species names in the AQ_species_list.input file in $AMETBASE/scripts_db/input_files/.

That should fix the errors you’re having.


1 Like

Hello @wyat.appel

Thank you so much for the response. I was able to figure out the issue (same as you mentioned here) and solved it successfully.


1 Like