Anyway to edit Dataset Type File Format in EMF?


#1

I downloaded and installed EMF v3.2 but am having trouble with my first attempt to use the software. I am attempting to import the ptegu point source FF10 file from the 2014 NEIv2 model ready datasets. The program complains about the header, saying that it expects FUG_WIDTH_XDIM but is finding FUG_WIDTH_YDIM. It appears that the Flat File 2010 Point format is incorrectly setup, because the SMOKE manual states that FF10 format should have FUG_WIDTH_YDIM and then FUG_LENGTH_XDIM. So, I went into the Dataset Type Manager and attempted to edit the column names. However, it does not let me edit the column names or add new ones (at least, it doesn’t save any changes).

The only option as I can see it is to create a new Dataset Type and add all the details of that Dataset Type manually. Or, I could change the headers of the input file and then change them back after I’m done using EMF.

Is there anyway to edit Dataset Type - File Format - Column names? Or am I stuck just using one of the two workarounds I listed?


#2

The Flat File 2010 Point dataset type was updated in EMF v3.0 to use the corrected labels FUG_WIDTH_XDIM and FUG_LENGTH_YDIM. The SMOKE documentation is out-of-date.

When importing older datasets (like the 2014 NEIv2 data), you can edit the column names in the text file to use the new labels, then import the files into the EMF. New datasets released by EPA will use the updated column names.