Bldoverlay compiling error with intel

The following is the error I get while make of bldoverlay with intel compiler.

“ifort -auto -warn notruncated_source -c module_sites.F
module_sites.F(60): error #5120: Unterminated character constant
CALL M3EXIT( ‘O3TOIOAPI’, 0, 0, 'Lambert projection setup err
module_sites.F(60): error #5082: Syntax error, found END-OF-STATEMENT when expecting one of: :: ) , :
CALL M3EXIT( ‘O3TOIOAPI’, 0, 0, ‘Lambert projection setup err
module_sites.F(70): error #5082: Syntax error, found END-OF-STATEMENT when expecting one of: :: ) , :
&Lat/Lon to Lambert to conversion error’, 2
module_sites.F(45): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [M3UTILIO]

I am aware that the error is due to the compiler settings in the Makefile. But could not figure out exactly where is the mistake. Kindly advice.

Thanks in advance.


You need to tell the compiler to use non-Standard "fixed 132-column " source format.
See the make-variable E132 (=-extend-source 132) in the ioapi/Makeinclude.$BIN: which has the flag for using this non-Standard Fortran-source format.

This value belongs in the *Makefile"'s make-variable f_FLAGS.

I have done that Sir. But there are still some errors. Can you please send me a sample Makefile.



Makefile.txt (2.7 KB)

Here’s the gcc/gfortran medium-memory-model Makefile. You need to replace the

-ffixed-form -ffixed-line-length-132

by the appropriate ifort-flags for fixed-132 source format.

Sir, attached is the Makefile I have used and the error it generated. I did replace the ifort flags but I guess its not enough. Kindly advice where is the mistake.

error.txt (12.2 KB) Makefile-ifort.txt (2.4 KB)

Thanks in advance.

Your Makefile’s flags needs to match the corresponding ioapi/Makeinclude.$BIN flags – in particular, either -openmp for ifort Version 15 or earlier, or -qopenmp for later versions.