AMET tier 3 program


I am trying to install AMET for the first time. When running make to compile the “combine” program, I got this error.

I am using the ioapi and netcdf libraries I used for CMAQ. I do not know what led to the error and would so appreciate it if anyone can help with it.


Makefile.combine.txt (2.1 KB)

make can’t find mpiifort, which is a particular MPI-enabled wrapper built around the Intel Fortran compiler ifort.

combine doesn’t need MPI. But bldmod assumed that everything that you’re building does (and unless you’re building the CMAQ CCTM, nothing that you’re building needs MPI.

Assuming you used binary type BIN (e.g., Linux2_ia64ifort) to build your I/O API and netCDF, try putting the attached Makefile.combine.txt (sorry about the “.txt” extension, but the Forum software insists on it) for your particular installation into the BLD… directory for combine, edit it for your I/O API installation (change the
line to match your I/O API installation-directory), and then doing a command that uses that BIN, like

*make -f Makefile.combine.txt BIN=Linux2_ia64ifort*

It will be very like building the m3tools programs, except that the build-directory and the source-directory are the same…

Thanks for the guidance. I used your makefile.combine to replace the original one but got another error. This time, make could not find ifort. Except for the ioapi directory, anything else I need to change?


This says the (build type dependent) Fortran compiler is not in your current PATH.

Did you build the I/O API (library libioapi.a and m3tools programs)? If so, what build-type did you use? (From what you had written earlier, I was assuming you did Linux2_x86_64ifort, which assumes you used the Intel ifort and icc compilers. In which case, what does the command

which ifort


You need to use that build-type as the BIN in the make-command I gave you.

If you didn’t build the I/O API, then: did you get it from somewhere; and if so, what BIN-type was used? …and do you have the compilers installed properly for that build-type? If not, you need to install them.

Hi cjcoats,

Thanks for your help. These errors were solved by changing some environment settings and adding -qopenmp for Intel in LINK_FLAGS. I also modified the script you gave me to compile other tier 3 softwares.