BlueSky2Inv Error while running with BlueSky Pipeline output

Hello everyone,

I ran the BlueSky pipeline with one of the example JSON files it comes with. Then when I try to run BlueSky2Inv with the output generated from the pipeline it gives out this error:

*** ERROR ABORT in subroutine BLUESKY2INV
     Could not find FIPS code********  in COSTCY file

I use the existing COSTCY file in the ge_dat directory and attached the input and output JSON files. I ran the input with fuelbeds, ecoregion, consumption, and emissions in bluesky pipeline.
1-fire-24hr-20190610-CA.txt (1.2 KB)
one_fire_output.txt (298.2 KB)

Do you know how I can solve this issue?

The BlueSky2Inv program is obsolete and generates IDA inventory files that current versions of SMOKE no longer support.

We suggest you use the extrafileswriter for emissionscsv to get the needed emissions:

There is not a BlueSky native post-processor so from there you need to determine a way to convert the emissions CSVs to the FF10 format currently used by SMOKE

Thanks you for your help @eyth.alison . I’m going to try what you’ve just mentioned. Meanwhile, are there any other ways (i.e. models) to calculate emissions for different fires which are more compatible with SMOKE and eventually CMAQ?

To my knowledge there is not another option for calculating wild land burning emissions that outputs directly to an inventory format that is currently SMOKE compatible. BlueSky is used for the NEI and platform fire inventories with post-processing done to get FF10s following the formats in the SMOKE manuals.

I’ve put in a feature request to add native FF10 output to BlueSky so that direct inventory output may be possible in the future.