CCTM stops when running CMAQ-DDM-3D

Hello, I use cb05tucl_ ae6_ AQ recompiled my CCTM, but I don’t know why it stopped halfway. There is no error in the log file. My input files are icon, bcon, mcip and emis.Please help me have a look or tell me what to do next to make my CCTM run normally.
log:This is what appears on the screen when I run the script;
log.txt (26.5 KB)
CTM_LOG_001/002:This is the log file automatically generated after running the script. There are two different files.
CTM_LOG_001.v52_intel_HUABEI_20200101.txt (53.8 KB)
CTM_LOG_002.v52_intel_HUABEI_20200101.txt (48.2 KB)
run_d01_cctm.csh:This is my running script for CCTM;
run_d01_cctm.csh (26.4 KB)
emis.txt:This is ncdump -h my EMIS input file.
emis.txt (18.0 KB)

Hello,can anyone answer my question?I will be very grateful.

I see this in your log file:

 ***  ERROR in INIT3/INITLOG3  ***
 Error opening log file on unit        99
 I/O STATUS =        10
 File: /MODEL/CMAQ/v52_intel_HUABEI.log

Try deleting your old output files first and running again. If it still crashes, search for the error message in your log file and post that.

Sergey

2 Likes

Thank you very much for replying me. I’m running DDM module of CMAQ5.3.3, there is still no error in the CTM log. I will upload my log and run script for you to check whether I should turn on or off any switch. I sincerely thanks your guidance. Thank you very much!
CTM_LOG_019.v533_intel_HUABEI_20200702.txt (66.8 KB)
D02run_cctm_ddm.csh.txt (35.2 KB)

Because a log-file for a program-execution must be unique to that particular program execution, the LOGFILE is opened with STATUS = 'NEW'

You must remove previous log-files (or else ensure that they are named uniquely) before running the models.

Or else you should not be using LOGFILE and instead should be re-directing STDOUT: see https://cjcoats.github.io/ioapi/ENVIRONMENT.html:

LOGFILE… This facility was provided for use with (now-obsolete) devices like CalComp plotters that hijack STDOUT.

1 Like

Thank you.I add # before LOGFILE $CMAQ_HOME/$RUNID.log in the runscript, It won’t appearance the sentence that Error opening log file on unit 99 , but I still can’t run successfully. I made a list of reducing 30% NOx and put it into it for calculation. I’m not sure whether this is correct. Maybe DDM calculation doesn’t need another list file. Please check my script and the settings of sensinput file. What’s wrong with me? Why can’t it run? I also uploaded the log for your reference, I sincerely look forward to your guidance! Thank you very much~
CTM_LOG_001.v52_intel_HUABEI_20200702.txt (46.0 KB)
run_d01_cctm.csh (26.6 KB)
sensinput.cmas.dat.txt (56 Bytes)

You can’t just comment out the LOGFILE definition in the run script. You must remove the old files from the disk. What does your log.txt file look like now - the one you posted in the original question for the screen output? Look there for the error.

Also, consider trying to run just CMAQ without DDM for the benchmark case with the provided inputs. Perhaps, you are trying to jump too far from the start. There are tutorials and instructions in the User Guide available with code. Please, read those. If can successfully replicate the benchmark, then add complications like your own episode and/or DDM.

Sergey