CMAQ-5.0.2 compile error

Hi everyone,
When i compile CMAQ-5.0.2, i got the following error:


My ioapi-3.1 is successfully installed and it is linked to the lib directory.
What should be the reason that causes this error? Any suggestion is appreciated.
Lin

It is always helpful if you copy the text of the command that generated the error-message, as well as the message itself.

The problem is that “Error in opening compiled module file…”

Find the I/O API build directory (which will have m3utilio.mod and libioapi.a and a lot of other .o-files and .mod-files in it); for the following suppose that directory was /foo/bar. The compile-command that failed should have had an include-directive for that directory in it – something like
-I /foo/bar

This probably means that you did not follow the instructions for setting up CMAQ and running bldmod correctly…

Thanks for your reply. I am trying to compile pario by using “./bldit.pario” and the error appeared. I tried “./bldit.pario -I /home/zye01/libs/ioapi-3.2/Linux2_x86_64ifort” but it did not work(same error message).
Attached is my config.cmaq file.
Thanks!
Lin
config.cmaq.txt (3.5 KB)

CMAQv5.0.2 was released in April 2014, over 7 years ago. We recommend you update to CMAQv5.3.2, released in October 2020.

If you must use v5.0.2, then you will need to debug the build script. I recommend setting the option to build the Makefile but do not compile. Examine the Makefile that is generated. It should have a setting that will tell the compiler to include a directory for the compiled module files. If you are using the Intel compiler, that flag is of the format you typed above, but you can’t append it to the bldit.pario command. Once you have set the include flag appropriately, invoke make to compile the model.

That works! Thanks so much!!
Lin