ERROR ABORT in subroutine VDIFFACMX on PE 055

I was running a year-long simulation from 1st January to 31st December. But my run is aborting on 2nd March. It is not creating the C_SGRID file for 2nd March. My log script is showing the following error:

—>> WARNING in subroutine GET_EMIS on PE 055
Could not read HGIIGAS from EMIS_1
M3WARN: DTBUF 22:49:00 March 2, 2016 (2016062:224900)

 Calculating emissions point source layer fractions for 224900

 Maximum eddy diffusivity of:   185.79     (m**2/sec)
 at col, row, layer:  12,  16,  22
 corresponding to a free tropospheric wind shear of:  2.94289E-02 (/sec),
                        a bulk Richardson Number of:   1.3720    ,
 and pot. temps. in layer and layer+1:   294.06       297.68    

SEDDY, MBAR, FNL, HOL = 2.6432292E-06 8.9718026E-07 0.2480207

 *** ERROR ABORT in subroutine VDIFFACMX on PE 055       
 *** ACM fails ***

PM3EXIT: DTBUF 3:28:04
Date and time 3:28:04 (*******:032764)

I am not understanding what the error message is pointing or what should be my next step.
I followed the thread regarding ’ why C_SGRID is not creating and check with the run script settings like MAXSYNC etc. I also found that previously one person got the same error, but could not reach any decision from that thread. I would be grateful if anyone can help me with this issue.

As a first check, let’s see whether the data is in fact missing for file EMIS_1 and date&time 2016062:224900 – a quick and easy way to do that is to run M3Tools program m3stat:
% setenv EMIS_1 <path>
% m3stat EMIS_1 DEFAULT >& EMIS1.stats
and then look at EMIS1.stats with your favorite text editor to see whether it also says that date&time is not available. If it isn’t, it probably means something went wrong (or missing) with your emissions processing…

Thanks for your suggestion. I tried to run the M3Tools and getting the error “m3stat: Command not found”.
May be I am not running it properly. Actually, I just follow the above mentioned steps in my CMAQ_HOME directory. Do I have to compile/bluid anything before running the m3stat commnad?

If you built the I/O API, you will have also built the M3Tools programs; after the build. they will be found in the same directiory as libioapi.a. You might do well to add this directory to your PATH. See

Among these programs is m3stat, which is documented at


I appreciate your help. That was helpful. I did check the Emis_1 file and it looks like no data is missing for (2016062:224900). Do you have any other suggestions for me?


I think something may be wrong with the scripting here: that

Date and time 3:28:04 (*******:032764)

suggests that something has gone wrong with the date-handling…

Thanks for your suggestion. As I am very novice in this field, could you please also suggest some potential files to check which I might have the problem. Sorry for bothering you repeatedly.