Error in reading CGRID with EMIS_SYM_DATE=Y

I am using CMAQ version 5.3.1. When a simulation for the second day (2018306) was executed, a following error occurred.

 Requested date & time:      2018305:005959
 File starting date & time:  2018306:000000
 File time step:           010000

 >>--->> WARNING in subroutine RDTFLAG
 Time step error for file:  INIT_CONC_1
 M3WARN:  DTBUF 0:59:59   Nov  1, 2018  (2018305:005959)

 >>--->> WARNING in subroutine XTRACT3
 Time step not available for file:  INIT_CONC_1
 M3WARN:  DTBUF 0:59:59   Nov  1, 2018  (2018305:005959)

 *** ERROR ABORT in subroutine retrieve_time_de on PE 029
 Could not extract INIT_CONC_1                              file

PM3EXIT: DTBUF 0:59:59 Nov 1, 2018
Date and time 0:59:59 Nov 1, 2018 (2018305:005959)

There were problems with unintended date and time in reading CGRID.

In this simulation, EMIS_SYM_DATE was set to be Y because I wanted to use a emission file with a timestamp different from the simulation date. It has the timestamp of 2018305. When I prepared a file with the timestamp of 2018306, which is coincident to the simulation date, this error did not occur. Therefore, I suppose this error is somehow linked to EMIS_SYM_DATE.

Any help is greatly appreciated.

Thank you for reaching out. A solution to this issue has been found and implemented but not yet released. You may find a description of the fix and a link to an updated I/O source file here:

Thank you for your reply. I updated the source as suggested but this problem was not solved. I am sorry if I did something wrong.

Thank you for reporting back. Today we have posted an additional bugfix that we hope will solve the crash when reading time-dependent initial conditions that could occur when using representative day emission input files. A description of the fix and a link to the updated source code file can be found here:

Thank you for your patience,


Thank you for your information. The updated source code worked well.