Error in running RPP sector

Hi everyone,

I’m using EPA’s 2014v7.1 SMOKE platform. While I try to run the RPP sector for both US and California, I face an error. I’ve attached the screenshot of the error and log file. Although I double-checked the case inputs and especially the eftables, I couldn’t find anything odd. I appreciate any thoughts and helps.

movesmrg_RPP_onroad_ca_adj_cb6orig_jun_2014fd_cb6_14j_20140601_12US1_cmaq_cb6.txt (2.2 MB)

Based on your log file, meteorology (daily min/max) input file created by Met4Moves utility tool for RPP mode run in Movesmrg does not cover the date you are processing. You need to generate the proper METMOVES input data using Met4Movers with your annual MCIP input file. Check the user’s guide for details. We

I generated the needed meteorology input file using met4moves. I did run the
“Monthly_onroad_ca_adj_RPP” and got the outputs without any errors. However, when I try to run “Monthly_onroad_RPP” the following error occurs:

I also checked “m3stat_onroad_cb6orig.rpt” and there are some negative values for some species. How can I avoid the negative ones, and what is the reason?

The error shown here is due to m3stat identifying negative values in the emissions. RPP has some negative emission factors due to some very high VMT/VPOP ratios in counties
with low population but lots of through traffic, like you see in parts of Texas. This results in some negative emissions, which trip the error checker The latest version of SMOKE accounts for this and resets all negative values to zero. So, updating to the
latest SMOKE version is one solution. Alternatively, one could live with it - negatives are offset by positives in other sectors in almost all cases – and turn off m3stat so that the job doesn’t stop upon seeing this. To turn off m3stat, add this line to run_settings.txt:

[sector name e.g. onroad_ca_adj], [grid name e.g. 12US1], m3stat, PART4, 0, 0, N

1 Like

Thank you, that worked!