SMOKE - 2016_beta - RPP

I’m using the 2016_beta platform to process emissions over two nested domains, 4 km and 1.33 km, but I’m getting hung up on the RPP sector in the 1.33 km domain. RPP worked fine in the 4 km domains and the other 1.33 km onroad sectors proceed without error as well. The error I’m getting is:

 *** ERROR ABORT in subroutine MOVESMRG
 Could not find minimum or maximum temperatures for county 000000017197 and episode month         7
 Date and time  0:00:00   July 1, 2018    (2018182:000000)

Oddly, 17197 is not a representative country, and I have ef_tables for it’s representative country (17043). I’ve tried adding lines to both MFMREF to describe representative months for 17197 and MRCLIST (mrclist_RPP_2016v2_AQ_CB6_11oct2018_18oct2018_v0) so that even if it does choose 17197 as a representative county, it points to the actual representative county file (i.e., 17043).

This line is in my MCXREF file: 0,17,197,0,17,43

I’m not sure what else try - but I’m wondering if it is an issue between my grid and the daily min/max temp file I created with met4moves. Though why the 4 km would work and not 1.33 is not clear to me. Any help is greatly appreciated - Thanks!

I believe I discovered the error - My min/max temp file was created with the alpha platform, which does not include surrogate 506 in the met4moves runscripts. In any case, regenerating the file with the beta platform solved the issue (still not clear why the outer domain went ok)…