Error termination. Backtrace:(wrmrgrep.f)

I have run smoke(point) for 9 days of metrology. I have not received any error in my log file but I got an error in the terminal.

At line 689 of file /home/farzad/SMK_HOME/subsys/smoke/src/smkmerge/wrmrgrep.f
Fortran runtime error: End of record

Error termination. Backtrace:
#0  0x1498d7651d21 in ???
#1  0x1498d7652869 in ???
#2  0x1498d765354f in ???
#3  0x1498d7895e10 in ???
#4  0x1498d78995d4 in ???
#5  0x1498d78999d3 in ???
#6  0x55e26dcb0c6c in ???
#7  0x55e26dcb28a9 in ???
#8  0x55e26dcb6309 in ???
#9  0x55e26dc7f7e3 in ???
#10  0x55e26dc7b83e in ???
#11  0x1498d72f40b2 in ???
#12  0x55e26dc7b89d in ???
#13  0xffffffffffffffff in ???
8.180u 1.532s 0:10.23 94.9%	0+0k 0+1920896io 0pf+0w
SCRIPT NOTE: exiting qa_run.csh without running QA.
             QA_TYPE  = all
             RUN_PART1= N
             RUN_PART2= N
             RUN_PART3= N
             RUN_PART4= Y

you can see what happened in the terminal in this text file.
terminal.txt (24.5 KB)

could anyone help me?

I believe I have seen this bug before. Can you run Smkmerge without any summary report by setting the following flags to N?


Hope this fixes the problem. let me know if not.

BH Baek

Thanks for your response. @bbaek
It worked. :pray:

8.144u 1.556s 0:10.65 90.9%	0+0k 21272+2000856io 91pf+0w
SCRIPT NOTE: exiting qa_run.csh without running QA.
             QA_TYPE  = all
             RUN_PART1= N
             RUN_PART2= N
             RUN_PART3= N
             RUN_PART4= Y

Does not matter program exiting without running QA?

You can use Smkeport to generate the same kinds of summary reports if you desire. You do not have to use Smkmerge for those reports.

1 Like

I met the same problem ,and this error still exist after follow your advice.Do you have any other solution or suggestion.

Which sector are you processing? Can you share the error message? Did you turn off all flags starting with MRG_REP* ?

Hi bbaek
Thank you for your help.The sector that I ran was smk_point in smokev4_0, I had solve this problem by change the CSV to TXT format, but do not know why .However, the new peoblem appears ,and there is no such file in dirctory.Could you please tell me which script control this.

The error message said that there is a missing output file from Smkinven program. Please check your Smkinven log file and make sure that it ran successfully with “Normal Completion” at the end of file.
When you had a problem in Smkinven previously, you need to manually delete all output files previously created by Smkinven first. Then rerun Smkinven as a fresh start.

1 Like

Hi Bbake
Thanks for your advice.The png I provided is a screen shot of the log file.Of course , “Normal Completion” can not be there.In addition ,I tryed to delete all temp and log files which produced by last run ,but the Error is the same .

That means you need to FIRST successfully run Smkinven program with “Normal Completion”. Without the successful run of Smkinven, none of programs will run. All runs for that sector will fail. Please review the error message from Smkinven log first and address them accordingly.

1 Like

Hi Bbaek
Thanks for your help.I solved this finlly .Because the input CSV only have one pollution and the ‘keep’ parameter of invtable was setted to ‘N’,which caused this peoblem.