Error to use latlon code

Hi all,

I tried to run ioapi command latlon to create one file with lat and long.
My GRIDDESC includes below information
’ ’
2 33.000 45.000 -97.000 -97.000 40.000
’ ’
‘LAM_40N_97W’ -2556000.000 -1728000.000 12000.000 12000.000 459 299 1
’ ’
There is an error:

 "BDYFILE" opened as UNKNOWN(R-W)
 File name "BDYFILE"
 File type BNDARY3
 Execution ID "????????????????"
 Grid name "12US1"
 Dimensions: 299 rows, 459 cols, 1 lays, 4 vbles, 1 cells thick
 NetCDF ID:    131072  opened as READWRITE
 Time-independent data.

Failure: status 9 in GTPZ0 at K= 765

 *** ERROR ABORT in subroutine MODGCTP/XY2XY1D2
 LATLON::GRID1 coord-transform error(s)

When I reduced the grid numbers, no error, so it may be due to too large domain?
Could anyone help me about this error?

Thanks in advance.

299x459 is not that big a grid – I’ve worked with grids of about 2500x3500 with no trouble.

Which version of “latlon” ? (See the program’s splash-screen). The current version is

$Id: latlon.f90 199 2021-05-07 17:20:03Z coats $

sorry, I don’t know how to check the version, I just got it from NEI2017 folder.

I tried a new one from my group member, it works now. thank you.