Error when running Benchmark data of CMAQ v5.3 on Ubuntu18

Dear Sir:
I am using CMAQ5.3 on the ubuntu18.04, I have compiled CCTM to get CCTM_v53.exe. My Compiler is gcc 7.4.0, when i am going to run benchmark data(2016_12SE1),the command line Tip is: “source: Too many arguments.”
Could you tell me what should I do?
$ ./run_cctm_Bench_2016_12SE1.csh gcc 7.4.0
Start Model Run At Mon Nov 4 14:14:55 CST 2019
source: Too many arguments.

Best wishes
MingHui Chou

I believe the error “source Too many arguments” is telling you that the script is only expecting one input, rather than 2.
Please try runnning without the version number
./run_cctm_Bench_2016_12SE1.csh gcc

I have the same error as Minghui, and running without the version does not work either. Could you help with this?
Lin

Please examine the run script for CMAQv5.3.

The version of the run script that I have does not expect any inputs, as it uses environment variables to set the compiler and version number. This approach has been modified over time.

#> Choose compiler and set up CMAQ environment with correct 
#> libraries using config.cmaq. Options: intel | gcc | pgi
 if ( ! $?compiler ) then
   setenv compiler gcc
 endif
 if ( ! $?compilerVrsn ) then
   setenv compilerVrsn Empty
 endif

#> Source the config.cmaq file to set the build environment
 cd ../..
 source ./config_cmaq.csh $compiler $compilerVrsn

If your run script looks identical to the above, then please try running the script without any inputs as follows:

./run_cctm_Bench_2016_12SE1.csh 

Thanks liz, my run script looks identical to yours, and i tried running it without any inputs but it still does not work. Attached is my run script.
run_cctm_cb6mp.csh.txt (36.4 KB)

Can you try to modify the line

cd ../..
source ./config_cmaq.csh $compiler $compilerVrsn

to

cd ../..
source ./config_cmaq.csh $compiler

I can’t seem to reproduce your error, but perhaps this will solve it.

1 Like

Yes, my problem is solved! Thank you so much!!
Lin

1 Like

I still could not solve this problem, Could you contact me? I am Cheinese, My QQ is 237577653