Error when running CCTM with simulation start time

Dear CMAQ forum

I am new to CMAQ and I am running CMAQ v5.3 emulation test against my domain and got an error setting:
set STTIME = 010000
set NSTEPS = 230000
set TSTEP = 010000
but it’s done when placed
set STTIME = 110000
set NSTEPS = 130000
set TSTEP = 010000
That means: when setting the start time from 01 to 10 o’clock there is an error and when starting at 11 o’clock it is complete (with log file attached run_cctm_12SE1_01-2015.log.err.txt (12.1 KB), CTM_LOG_000.20-01-2019_20190120.err.txt (120.5 KB), run_cctm_12SE1_01-2019.csh.txt (33.9 KB), run_cctm_12SE1_01-2019.log.txt (275.6 KB) ). I attached the file to run csh.

The problem is that I think my input is full 24 hours (starting from 00-23 hours) and I have attached the file that runs MCIP (run_mcip_01-2015.csh.txt (16.9 KB)).

Any of you know how I can fix it?
Appreciate your kind help.

Nguyen Dong.

Comparing your log files, the crash occurs in PHOT (photolysis), but I cannot tell what the specific problem is.

Program received signal SIGFPE: Floating-point exception - erroneous arithmetic operation.

Backtrace for this error:
#0  0x7f10b48afef7 in ???

Recompile the model in debug mode. This can be done uncommenting

set Debug_CCTM

or by going into the BLD directory and typing:

make clean

Once the model is compiled in debug mode, rerun the model. It should produce a stacktrace that indicates the line number where the crash occurs, that will help diagnose the root cause of the problem.

Dear cgnolte.

Thank you very much for the guidance.
I have followed your instructions and have the error log file (I am attached here run_cctm_12SE1_01-2019.log.txt (12.4 KB) ), looking forward to your next guidance.

Thanks, again.
Best regards.

I do not understand what is wrong. The stack trace indicates a crash on line 148 of o3totcol.f:

 if ( nrecs .gt. 0 ) nt = nrecs / nlat

If nlat equals 0, then the above line could lead to a crash consistent with what you are seeing. But nlat should not be 0, or if it is, you should get earlier errors about the model being unable to open or read the OMI file.

Were you able to run the benchmark case successfully?
What is the landuse scheme in your WRF runs?

Dear cgnolte

  • I just tried running the benchmark case and it is fine (here is the log file cctm.log.txt (226.3 KB) ).
  • I use the modis landuse scheme in my WRF 4.1.

Please try again with version 5.3.1. Compile it in debug mode.
Conduct two runs:

  1. Set STTIME = 000000 and NSTEPS = 020000.
  2. Set STTIME = 110000 and NSTEPS = 020000.

(Since your crash occurs immediately, it is not necessary to run the case that works for very long. Two hours is more than enough.)

For both runs, please upload the main log file and the CTM_LOG_000 file. Please give them different RUNIDs so that it is easy to distinguish them.

Dear cgnolte
I apologize for now I have answered you.
There are many things I have to do in the past time and cannot try to follow your suggestion.
Today I tried again and found out there was an error in using omi file (after initializing omi file, I used omi_full_2019.dat instead of omi_cmaq_2019.dat).
Currently I have successfully done my simulation.
Anyway I am very thankful for your attention and sharing.

Again very sorry to you for the delay.

Best regards.

1 Like

Thanks for reporting how the problem was resolved. I believe it is the case that this issue has been resolved in v5.3.1, and that the model aborts with a better error message if the wrong OMI file is used.