Fortran runtime error

Hi, everyone. Based on my previous post, I re-run WPS and WRF to get a new domain to try to simulate with the EQUATE 12us1 emission file. I successfully run the simulation. However, it stopped at 01:55 during the simulation. The log is in the attachment. As the error message shows ‘100’ is also the configuration in my GRIDDESC. So I will also attach my new GRIDDESC here and I hope it will help
run.cctm.log.txt (34.7 KB)
GRIDDESC.txt (203 Bytes)


Thanks for following up, this is an interesting error and something we aren’t expecting. My first guess would be this is something unique to your test case.

As such could you upload your runscript, met files, and initial and boundary condition files as before. See the instructions on the last forum thread to do so.


Hi, I have used one domain which is 69*69. The error shows 85 larger than 69. That is why I modify the namelist.wps to make a larger one. I am afraid it is still relation with GIRDDESC and I will send the file later.

HI, Fahim. I have uploaded a file “2019_0802_SGP.tar.gz” in the incoming folder. I also attached my namelist.wps cause I think it might help.

Thanks for your help!

1 Like

Hi, Fahim. I have something to update for your information. I am trying to reproduce the errors in my own workstation which is on ubuntu24 with x86 architecture intel xeon cpu. However, the errors does not happen on it. It happens in the HPC with ppcle64 architecture and RHEL. I hope this can offer your some information and I may need to check the version of the library.


@hogrefe.christian and I both tested the test case you uploaded and did not encounter the same error as you. However, note that both of us are on the same system (x86 architecture with RHEL8 OS).

At this point, we can’t offer you much help as we don’t have a ppcle64 architecture to test on, but can offer a suggestion:

  1. Since you successfully ran the benchmark domain on this workstation, have you tried to run the entire CONUS domain provided through the EQUATES platform? Or perhaps, you can try to window the EQUATES emissions inputs using the m3tool m3wndw to the small domain you created, similar to what the benchmark files provide. This suggestion is based on the hunch that the size of the problem is giving you some issues on the ppcle64 architecture.

Lastly, take note that your MCIP output has 24 output steps not 25, which with your runscript fails to run hours for 23:00:00 Aug 2, 2019 - 00:00:00 Aug 3, 2019, as there are no met data to interpolate fields between those two times. Just something worth noting, but not related to your actual issue.

Hi, Fahim. I almost get the same output with my own workstation. Even the MCIP problems are the same. For the conus domain through the EQUATES platform, I have run one simulation on 20200801. I think it is fine so I will use m3wndw to try to figure out the problem. I will mark this as solved and if I have any updates. I will let u know.

1 Like