How to use AMET without mySQL?

Dear all;

Since our High Performance Computational Platform does not allow to use mySQL server, I need to analyze the CMAQ outputs without mySQL. I have downloaded the 2014 observational data, so there is no need to obtain observation data from other networks.

Could you share me some thoughts of using AMET R scripts without installing mySQL, if possible?

Thanks very much!


I download and installed AMET_v14. What script shall I run to compare observation and model results only using the R analysis in AMET? The issue stuck me is I don’t have mySQL in the system.

Thank you!

Hi Yijia,

First, I should say that only the air quality side of AMET currently will function without a database present. So, you won’t be able to use AMET to process and analyze meteorological data with the database.

You can use AMET-AQ without a database present. The AMET User’s Guide explains how to do this. I suggest referring to that guide for more detailed instructions of what I will explain here.

In short, to analyze air quality data without the database, you’ll skip any steps that require a database. That includes initial setup of the AMET database, creating an AMET database user, etc. In the AMET-AQ example run scripts in the scripts_db directory, you’ll want to set the LOAD_SITEX flag in those scripts to “F”. This will tell AMET not to load any data into the database. In the analysis scripts in the scripts_analysis directory, you need to set the AMET_DB flag to “F”. This tells AMET to read the observed/modeled data directly from the site compare csv files and not the database.

Note that not all AQ analysis scripts will currently work without the database present, but many will. Please report any issues you run into. This is a new feature in AMETv1.4 and I’m looking for feedback.

Thanks and good luck!



Thank you, Wyat! Your suggestion is very helpful! Appreciate!


Dear @lizadams, @tlspero, @wong.david-c, @bbaek, @cgnolte, @zyj.jess, @hogrefe.christian, @wyat.appel,

Can AMET be used for model evaluation outside USA? For instance, I am based in China. Can I use it to evaluate my models?

Thanks in anticipation.



Yes, AMET can be used outside the US. It does not have a geographical limitation. If you plan to use AMET for China, you will however need to obtain AQ observation data as there are currently no AQ data available to provide for China. Meteorological data are available outside the US however.


1 Like

Dear @wyat.appel,

Thanks for your prompt response. I’ll give it a trial and get back to you for any assistance regarding its usage.

Kind regards,


Hi Wyat,

I am also trying to use AMET-AQ without mySQL. Based on your suggestion, I set LOAD_SITEX
to T when running aqProject_post_only.csh. But I still got errors related to mySQL. Is there anythig else I need to change? Really appreciate your help!


Hi Qian,

To use AMET-AQ without the database you should actually set LOAD_SITEX to F, not T. Where was it suggested that LOAD_SITEX should be set to T to use AMET-AQ without the database? I may need to correct that if that is the case.

Let me know if that helps solve your errors.




I am sorry. It was my typo. I did set it to F but still got these errors related to MySQL.
The script I am using is aqProject_post_only.csh (7.1 KB)

Hi Qian,

I agree there is an issue here. It appears this script will attempt to execute some MySQL commands regardless of the setting of the LOAD_SITEX flag. So, I’ve modified your script slightly (new version attached) to include a new flag AMET_DB which, when set to F, should eliminate the execution of the MySQL commands. Please try the new script and report back to me with the result.

I’ll admit I have not tested the changes yet, so I apologize if you run into any issues. But we’ll work those out quickly I’m sure. Thanks.

WyataqProject_post_only.txt (7.7 KB)

Thanks, Wyat! However, when I tried to use the new script, I got the error “./aqProject_post_only.csh: Command not found.”. Not sure what it means.

I also tried to add the “setenv AMET_DB F” to the old script but it still gave me the same error as before.

Try applying the command below to the file I sent. That might fix your issue.

chmod +x aqProject_post_only.csh

I changed the permission but it still did not work.

I guess I figured it out why it did not work. The file is saved in Windows format. I will convert it to Unix file format and let you know if it works

Ah, sorry. That’s my fault. Let me know if you’re not able to get it to work. I’m attaching a version that was created in linux just in case.aqProject_post_only_new.csh (7.5 KB)

1 Like

Hi Wyat,

I can run the script now but still got some issues. It seems the program is still using something related to MySQL. Should I run amet_config.R before running aqProject_post_only.csh? I am a little bit confused about how to configure AMET to set up the AMET environment as there is no detailed guidance in the Quick Start Guide.


I see. I obviously have some work to do to make this more user friendly. However, you could move the line

if ($AMET_DB == “T”) then

to before the line

setup metadata tables

Basically just moving it to after the amet login portion of the script. That should get you past your current issue.


1 Like

Thanks, Wyat. Moving the command solved this issue. However, new errors occurred. It seems to be related to the netCDF libraries settings but I do not know which file I should check.