MCIP cannot generate PURB (percentage of urban area)


Good evening CMAQ users:

I have been struggling on the MCIP during the past a few weeks. Most of the issues have been solved, and now it stuck on the generation of PURB, for which I could not find out the solution.
I used NAM to generate the WRF output file ( The MCIP output was successfully generated by the wrfout file. However, when I check the GRID_CRO_2D file generated by MCIP, the variable PURB was not generated. As a result, when I tried to run CCTM, it shows

 *** ERROR ABORT in subroutine INIT_MET on PE 000        
  Error interpolating variable PURB from GRID_CRO_2D

(I am using CMAQ5.2, and version 4.3 for MCIP)
My questions are:
a). Is PURB required for running CCTM? Is there anyway to disable it?
b). If PURB is required, how could it be generated by MCIP? Is there some settings in MCIP or WRF to make this happen? Or it is due to the input files of WRF? How could I prepare it?


MCIP error about LANDUSEF from WRF

I don’t know why PURB is not generated when MCIP creates your GRID_CRO_2D files. What version of WRF did you use? Perhaps you need to modify the WRF Registry to output an additional variable.
If PURB is not available, it should be possible to run CMAQ without it:
setenv KZMIN F
but it is recommended that you generate the PURB field.
There is some discussion of the issue in the release notes to CMAQ 4.6, but that was released 12 years ago.


Huan –

In order to create PURB (the percentage of urban area) in MCIP, you need to have the array LANDUSEF (fractional land use) from WRF. This array is not part of the WRF output (history) file by default, so you would need to modify the WRF Registry to add LANDUSEF to the output. If you did not automatically end up with PURB in your GRIDCRO2D output, it’s safe to assume that you don’t have LANDUSEF in your WRF output.

Alternatively, you can acquire LANDUSEF in MCIP by providing your WRF Geogrid output file in the MCIP script variable InTerFile. There should be some instructions in the MCIP script on how to set this up properly.

As Chris mentioned, you don’t need PURB to run CMAQ, and you can disable CMAQ’s need for it by following Chris’ instructions. However, it’s better for the science in the urban areas if you provide PURB to CMAQ via MCIP.

Hope this helps.


Hi Chris:

I am using version 3.8 for WRF. I just tried to run CCTM, after setting KZMIN from Y to N, it still comes out with the same error messages.
Maybe we cannot disable it for version 5.1?


 >>--->> WARNING in subroutine INIT_MET:INTERPX
 Variable "PURB" not in file GRID_CRO_2D
 M3WARN:  DTBUF 0:00:00   July 13, 2016 (2016195:000000)

 *** ERROR ABORT in subroutine INIT_MET on PE 000        
  Error interpolating variable PURB from GRID_CRO_2D


Hi Tanya:

I am not sure whether I did is correct, I changed IfTer to “T”. I also checked my geogrid output file, and it does include the variable LANDUSEF
set IfTer = “T”
set InTerFile = $InTerDir/
And now, the error messages come out when I tried to re-run mcip:
Inconsistent file attribute NVARS for file GRID_CRO_2D
Value from file: 6
Value from caller: 28



Huan –

Make sure you delete your existing MCIP files rather than try to overwrite them. Then try again.



Check your log file. Search for KZMIN. Do you get a message saying “This run uses Kz0ut, NOT KZMIN in subroutine edyintb.”? If not, then you are getting a default value, which is true. Be sure you are setting
setenv KZMIN F

I am not sure what would happen if you spell out

Note: this is only if you want to override the default approach for KZMIN. The recommended approach is still to obtain PURB.


Oh, it succeed!!
Thank you for help!


Hi Chris:
I just successfully generate the GRID_CRO_2D file by MCIP, with the help of Tanya. Thank you for your time and help~


that’s exactly what I did.
Does your file has the variable “LANDUSEF”?



I used WRF model to generate it



Li –

Please post the specific error you are receiving from MCIP. When you say that MCIP cannot find your geo_em file, it’s not clear if this is a script error or an issue in MCIP.



My MCIP problem was script error and I’ve sloved it. Really appreciate for your reply.


closed #21