Mcip running error

run_mcip4AQF5X_cron.csh (948 Bytes) run_mcip_AQF5X_cron.csh (18.7 KB) Hy,

I’m facing an error while running mcip. Please see the attached scripts.

error:run_mcip_AQF5X_cron.csh (18.7 KB)

 ~~~ Processing meteorology for time = 2020-06-01-19:00:00.0000

GETH_IDTS: Month of ODATE = 0
Screwy ODATE:
STOP odate_1
mv: cannot stat ‘/scratch/mrasel/data/mcip/out/200601’: No such file or directory
run_mcip_AQF5X_cron.csh (18.7 KB)run_mcip4AQF5X_cron.csh (948 Bytes) run_mcip_AQF5X_cron.csh (18.7 KB)

Hi Munshi,

  1. I am wondering if you defined your mcip out directory named “$mcp_dir” in config_cmaq.csh, .cshrc, or your script.

  2. Make sure InGeoDir should be your WPS output path with geo_em.d0?.nc files.

  3. I see following settings in your script and wonder if it works properly

    set MCIP_START = ${1}-18:00:00.0000 # [UTC]

    set MCIP_END = ${2}-18:00:00.0000 # [UTC]

add following check immediately after “set MCIP_END…”


make sure you have the valid start date and end one. You error message says you do not.

Otherwise, shift one hour late for start and end as following setting and see if it works.

set MCIP_START = ${1}-19:00:00.0000 # [UTC]

set MCIP_END = ${2}-19:00:00.0000 # [UTC]

I hope it is helpful.


  1. I didn’t see anything like $mcp_dir in config_cmaq.csh
  2. I’ve checked and my file is in InGeoDir
  3. I’ve checked and also changed the date to …:19:00:00

I’m still having the issues and it’s giving me the same error.

Any other suggestions?

Please double check, you do have

set OutDir = $mcp_dir #$DataPath/mcip/$GridName

in your run script file run_mcip_AQF5X_cron.csh
Do you have setenv mcp_dir somewhere? otherwise, output goes nowhere.

According to your error message

Processing meteorology for time = 2020-06-01-19:00:00.0000

The time stamp in your meteorology data seems not matching your start date

set MCIP_START = ${1}-18:00:00.0000 # [UTC]

So I doubt you have the right results from

It is better to attach your log file.


I set setenv mcp_dir in script (please see the attached [run_mcip4AQF5X_cron.csh file).

The script worked for 18th hours. However, at 19th hours it failed.

Also see the attachedlog.csh (39.3 KB) logout file:


I checked the code date_pack_mod.f90 (mcipv5.0), your error

GETH_IDTS: Month of ODATE = 0

resulted from moold = 0 (it should be 1-12), please double check time stamp in your meteorology data based on the following lines in date_pack_mod.f90

151       !  Check that the month of ODATE makes sense.
153       IF ((moold.GT.12).or.(moold.LT.1)) THEN
154          PRINT*, 'GETH_IDTS:  Month of ODATE = ', moold
155          opass = .false.
156       END IF

237       IF (.not. opass) THEN
238          PRINT*, 'Screwy ODATE: ', odate
239          STOP 'odate_1'
240       END IF

I hope it helps.


In my wrfout file I’ve checked (ncdump -v Times wrfout*) time stamp. It seems to me they are okay (please see the attached screen shot). Is there any other things I can check in my wrfout file?


Hi, @munshimdrasel ,

Go to source code directory and update the routine src/chkwrfhdr.f90 by commenting out line 447 as below, then try again after recompile MCIP. Please ‘make clean’ first before you re-compile it.

445       WRITE (*,f9000) TRIM(pname), 'SIMULATION_START_DATE'
446       WRITE (*,f9300) TRIM(fl1), met_startdate(1:19), TRIM(fl),  date_init
!!447       CALL graceful_stop (pname)

I hope it will be helpful.

1 Like


It worked. Thank you so much.