Option 3 - Inline NO without NLDN Data CMAQv5.3.1

Hi. Trying to run lightning NOx with option 3. Even though USE_NLDN option is set to N, the script is still trying to open the NLDN file.
Capture

Can you send me your runscript?

Thanks,

Daiwen Kang

kang.daiwen@epa.gov

The line NLDN:STRIKES : NLDN_STRIKES tells me that your script does not do the correct setenv command to set this environment variable to the path name for the corresponding file.

In fact, when we consolidated the I/O processes using centralized IO, a bug was introduced when setting the correct lightning input files. We are now trying to fix the problem. If you want to use current version of CMAQ code, one simple fix may be to have a pseudo NLDN_STRIKES file. It will run but do nothing. Or you can wait for us to provide a correction.

Thanks,

Daiwen Kang

Hi
Yes I have attached my run script. Thank you. So I can just put like a “mask” file as a place holder for the NLDN file? Will it still compute using the param file with that “mask” file in place for the NLDN file?
Bestrun_cctm_2019_4k-CMAQ_final_model_run_v2.csh (37.0 KB)

Hello I tried that. But still same error.
I was curious, if the error also has something to do with the initial conditions not having any data on NLDN strikes.

Hi
I thought it wasn’t supposed to look for the NLDN strike file if that option was false. I did go back and put in a mask file just to check (as was suggested) and still got same error.

Update: One of my team mates modified the centralized module and gave me his solution. It appears to be working. Thanks so much!

Hi @abi0010, can you post the solution to this issue? I ran into the same error and it would be great not to ask the same question again.

Hi @nsanzine. This is the solution given to me by @nashskipper. He modified the code, sent it to me. I then recompiled with the code and it worked. It is the centralized_io_module.F file under CMAQ/CCTM/src/cio. I have attached the original file and listed the modifications for it.

  1. After line 206 add the following

       logical :: USE_NLDN
    
  2. At line 827 Comment out the line

      if (cio_LTNG_NO) then
    

add this line in its stead

        if  (USE_NLDN) then
  1. Go to line 937, which should read as follows and comment it out

      if (cio_LTNG_NO) then
    

and add in its place the following

     if  (USE_NLDN) then

centralized_io_module.txt (195.2 KB)

@abi0010, thanks for the solution.