Problem when using CMAQ 5.3.1 with hybrid vertical coordinate

Hello CMAQ users:
I’m using CMAQ 5.3.1 with hybrid vertical coordinate, but got the following message:

Processing Day/Time [YYYYDDD:HHMMSS]: 2017181:000000
Which is Equivalent to (UTC): 0:00:00 Friday, June 30, 2017
Time-Step Length (HHMMSS): 000200
forrtl: severe (27): too many records in I/O statement, unit -5, file Internal Formatted Write
Image PC Routine Line Source
CCTM_v53.exe 00000000019DA5E3 Unknown Unknown Unknown
CCTM_v53.exe 0000000001A29D10 Unknown Unknown Unknown
CCTM_v53.exe 0000000000E0090A emis_defn_mp_chec 2234 EMIS_DEFN.F
CCTM_v53.exe 0000000000DA259E emis_defn_mp_emis 1228 EMIS_DEFN.F
CCTM_v53.exe 0000000000D5531F emis_defn_mp_emis 209 EMIS_DEFN.F
CCTM_v53.exe 0000000000FC9EA6 vdiff_ 266 vdiffproc.F
CCTM_v53.exe 0000000000E466C6 sciproc_ 232 sciproc.F
CCTM_v53.exe 0000000000E2DD3D cmaq_driver_ 679 driver.F
CCTM_v53.exe 0000000000E26600 MAIN__ 96 cmaq_main.F
CCTM_v53.exe 000000000040B49E Unknown Unknown Unknown 00002AC8FC3BA3D5 __libc_start_main Unknown Unknown
CCTM_v53.exe 000000000040B3A9 Unknown Unknown Unknown

Can anyone help me? thanks

Line 2234 in the EMIS_DEFN.F contains:

          WRITE( XMSG,'(A,A16,A,/,I3,A11,A16,A,/,A)' ),
     &              'ERROR: Surrogate Species ',TRIM(SPEC),' on emission stream ',
     &              ISRM, ' has units ',TRIM(UNITS),' which are unkown to CMAQ. ',
     &              'Please correct them to proceed.'

Line 2234 in EMIS_DEFN.F is in the section of the code that is checking the emission units.
The I/O Error may be an issue with writing out the error message that should alert the user that there is something wrong in either the emission control file or the emissions.
The emission control file is mechanism dependent, and is found in your BLD_* directory.


You likely need to review your emissions inputs and their consistency with the Emissions Control File.

Have you successfully used your compiler, mpi and libraries (netCDF and I/O API) versions to run the benchmark case prior to running using your hybrid vertical coordinate MCIP case?

Can you provide the following information:
compiler/version: gcc/9.1.0, intel/17.2, pgi
MPI version: openmpi 6.3.0, mvapich2.3
netCDF Version:
I/O API Version:

Thanks for your help.
I try to close all my emission file by setting N_EMIS_GR=0, the model works well. I found that the vertical layer in my emission file is 12, but the vertical layer from MCIP is 43. I’m not sure if it is necessary to keep the vertical layer the same between emission and MCIP when using hybrid vertical coordinate MCIP case?
By the way, the version of my compiler and mpi is intel/2017,
netCDF/4.1.3, IOAPI /3.2.
mechanism: saprc07tic_ae6i_aq