Resource Insufficiency Issue in CMAQ-ISAM Simulation


I am currently using the CMAQ5.4-ISAM model to simulate a case with 31 emission files at a 1 km resolution, and the total simulation period is one month. Our computing resources are set to automatically terminate simulations that run for more than 4 hours(walltime). To overcome this limitation, I’ve been using a daily restart approach with NSTEPS = 240000.

The simulations went smoothly for the initial days, but starting on November 11th, the computational speed significantly decreased. As a result, I can only simulate until 16:00 within a 4-hour timeframe.

Is it possible for me to modify the settings to allow CMAQ to simulate for 12 hours, generate CGRID files, and then continue the simulation with a separate job?

I appreciate your assistance.

Thank you.

I recommend checking with your IT department to verify the limit of 4 hours of wallclock time.
Is this limit for interactive jobs? Is there a slurm or other batch queueing system? There may be a batch queue that you can use that has a limit that would accomodate your job.

The other question is how many cores you are running, and if you could use more to reduce the wallclock time.

Can you share your job script, and the command that you use to run the job.