Segmentation Fault running MCIP 5.0

Dear all,

I’m having issues in running MCIP5.0. (with WRF4.1.3 inputs)
Apparently, it starts running, but at some point I get an error.

Log file (part of it)

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
mcip.exe 0000000000729174 Unknown Unknown Unknown
libpthread-2.12.s 0000003165E0F710 Unknown Unknown Unknown
mcip.exe 000000000044F016 gridproc_ 53 gridproc.f90
mcip.exe 000000000040EB07 MAIN__ 165 mcip.f90
mcip.exe 000000000040E79E Unknown Unknown Unknown 000000316521ED5D __libc_start_main Unknown Unknown
mcip.exe 000000000040E6A9 Unknown Unknown Unknown
Error running mcip

I checked all the names that I could be miswriting, and everything was ok.

If somebody has some input, please let me know.

Note: I changed IfGeo to .TRUE. instead of “T” because it’s not working with the latter (no idea why because it works with “F”). I posted this to answer @Catalyst2682 in another post about MCIP and it worked. (

Thanks in advance!!

run_mcip.csh (18.5 KB) mcip_log.txt (13.7 KB) namelist_mcip.txt (611 Bytes)

You can keep set IfGeo = “T” in you run-script. Just replace file_ter = “$InGeo” with file_geo = “$InGeo” in your script because geofile defined in the fortran code such as setup_wrfem.f90 and rdwrfem.f90, etc is file_geo rather than file_ter used in the original script we downloaded.
I hope it is helpful.




Thank you for your reply.

I changed as suggested, but I only found it in line 375 in my run_script.
And, unfortunately, I got the same error :cry:

Is there any other thing or line you think I should change?

Thank you anyway!

mcip.log.txt (13.8 KB) namelist.mcip.txt (689 Bytes) run_mcip.csh (18.5 KB)

I now know what happened to your case. Just comment line 286 in readnml.f90 and line 447 in chkwrfhdr.f90 which perhaps unnecessarily restrictive. Then try to run mcip again after recompile its source code.

! CALL graceful_stop (pname)

Do not forget to correct line 759 of the ctmproc.f90 routine according to Mcipv5.0 bug detected



Thank you for the reply. I’ll make the changes suggested and try again.
I’ll let you know how it was.

Dear @fliu,

I just tried your suggestion and it works very fine. And to my dear friend @thayna.gomes kindly try and recompile your mcip as suggested to you and lets know how it goes.



1 Like

@fliu @Catalyst2682

Thank you so much! It has run perfectly.


1 Like