SMOKE 4.8.1 ERROR: At least one message's priority is less than or equal to the exit priority: 1


SMOKEv4.8.1 is installed using gfortran compiler. I have successfully run sectors like “ptnonipm”, “pt_oilgas” from EPA 2016v2 platform.

Now, I am running a SMOKE case for the EGU sector from 2016v2 EPA platform. The ‘onetime’ script run is successful.

But when I ran ‘daily’ script , I am getting following error messages at the end.

Then I tried to see where ‘error’ is occurring in the output files. Here is the error messages that appeared in the output log files

Only error I can see is SMK_MAXERROR and Value for DEFAULT_CONV_FAC_ERROR.

I can’t find out the fix for these errors. Is the " ERROR: Level 1 errors or Level 0 warnings found" message is serious ?

Any suggestions and help would be greatly appreciated.

Please review Section 9 (log analyzer) of the README:

It seems like you have some priority=0 or priority=1 messages. You can look up what those warnings/errors are in the reports/log_analyzer “level 1” report, and see if those warnings are on the list of “acceptable” warnings included in the README, or if they are otherwise not important.

Hi @eyth.alison Thank you so much for the response. In the “level 1” report, I have only “Value for SMK_MAXERROR” and “Value for DEFAULT_CONV_FAC_ERROR not defined”.

So, I guess these are not important. And I can safely ignore these messages


Those two messages should be filtered out by the log analyzer “known messages”, and should not have triggered the “level 1 errors or level 0 warnings found” message. Can you please post your 1 file for our review?

Hi @eyth.alison ,

Thank you so much for the response. While I run SMOKE for the “WINTER” season, I found some more errors.

I understand, according to the Link SMK_MAX error and netcdf error number -40 can be ignored.

But I didn’t find anything about “Time step error for file: PHOUR” in that link. Is that error similar to
" Error reading netCDF time step flag for PHOUR" from that link?

Here are the log files for the “WINTER” runs.
rep_logs_ptertac_winter_2026fj_16j_12US2_NO_TAGGED_sum_level1.csv (24.6 KB)
temporal_ptertac_winter_dec_2026fj_16j_20161201.txt (590.2 KB)
temporal_ptertac_winter_jan_2026fj_16j_20160101.txt (587.4 KB)

The SMOKE programs (TEMPORAL, SMKINVEN, etc.) runs successfully. Can I safely ignore these errors?

Thanks in advance

Can you also provide the smkinven_ptertac_winter_[month]_daily_2026fj_16j logs?

We suspect your hourly data does not cover the full time period required for each month – e.g. it is missing the last day of the previous month (which is needed for time zone shifting reasons) – but the Smkinven logs would confirm this.

Hello @eyth.alison

Please see the ‘daily’ script used for this run
Annual_ptertac_winter_daily_12US2_2026fj_16j_NO_TAGGED.csh (8.0 KB)

Also, Please see the attached smkinven files
smkinven_ptertac_winter_jan_daily_2026fj_16j.txt (67.6 KB)
smkinven_ptertac_winter_feb_daily_2026fj_16j.txt (66.1 KB)
smkinven_ptertac_winter_dec_daily_2026fj_16j.txt (67.6 KB)

Thank you so much

For December, the last line in the Smkiven log is:

Timestep written to PHOUR for date and time 2016366:070000

So data is not bring written out for all of 12/31/16, which probably means there are no emissions on that date in the hourly FF10.

For January, the first PHOUR timestep is:

Timestep written to PHOUR for date and time 2016001:050000

To cover the first few hours of January, include a second hourly FF10 which includes December, in which the #YEAR in the header is the previous year (2015 in this case).

February looks fine.

1 Like

That looks like possibly a local-time vs GMT-time issue…

1 Like

Hi @eyth.alison @cjcoats

Thank you so much. Yes, Look’s like it’s PHOUR issue. We are trying to fix it. I will let you know the update.