SMOKE BEIS Custom BELD5 with our domain

We don’t have anything handy to support this right now. We no longer have tiles like we did for BELD4.

We have considered a program to support this in the future.

I wonder if you could prepare it at 1km for an overlapping grid and then write some sort of sampling process to pick the numbers from the grid cell with most overlap.

The Spatial Allocator might be able to take a 1km file and map it to your 1.33grid, but I’m not sure.

I’ll let you know if we decide to go ahead and prepare a program or function to support this.

1 Like

See my response that followed bbaek’s. We no longer have tiles – only the merged 1km dataset.

There are no individual tiles for BELD5, the full data for BELD5 are posted in the folder I pointed you to – it’s the big file

https://gaftp.epa.gov/air/emismod/2017/biogenics/BELD5_1US3_FIA6.1_2017CLD_Canada.ncf.gz

You should be able to derive the file for your grid directly from the data here.

https://gaftp.epa.gov/air/emismod/2017/biogenics/

aggwndw will not work because it has to be on the same projections AND a factor of 1km in resolution.

For example, it should work for 2km, 3km and 4km etc resolution but will not work for 1.33km.

@eyth.alison Are there any updates on the availability of a BELD aggregation tool that will work for 1.33km domains?

We have been trying out some different methods to make these files. Can you please send your grid description so we can test our new method(s) on it?

Sure! We will need files for our 1.3km resolution grids WF13UDAQ and UB13UDAQ.
GRIDDESC_udaq_v7.txt (993 Bytes)

We have posted some tools and applied them to your grids. Please give this a try:

https://gaftp.epa.gov/Air/emismod/2016/v2//beld5_regrid_scripts.zip

1 Like

This works for us - we now have BELD5 1.33km files for both our domains. Thanks for providing these tools!

1 Like


@eyth.alison Maybe I spoke too soon - I tried running BEIS 3.7 with the interpolated file for our WF13UDAQ domain. Normbeis crashes with missing emission factors from B3GRD. I took a screenshot of an ncdump on my WF13UDAQ B3GRD (above).

The output from the spatial allocator looks great in VERDI, here is an example:

Great news – thanks for letting us know…

Hi @eyth.alison - just flagging this thread again - the tool you provided works on its own to produce BELD files that look OK in VERDI. But the BELD files do not seem to be working with BEIS (see my most recent reply). I’ve never seen this error in running BEIS previously - could it be related to the BELD file from the tool?

We have tested the output files we produced with our version of SMOKE and BEIS. What versions of SMOKE and I/O API are you using?

Using BEIS 3.7 and smoke 4.8.1
Here is my run script
Annual_beis3.7_WF13UDAQ_2017by_17v2.csh (7.2 KB)

and my log file:

normbeis3_beis37_summer_2017by_17v2_WF13UDAQ.txt (10.5 KB)

If you haven’t tried this, you can try dropping the COL and ROW variables from the netCDF files output from the Spatial Allocator.

The log file didn’t make it FYI…

updated it - sorry about that. I’m not seeing COL and ROW as variables in my BELD5 1.3km netCDF. COL and ROW are dimensions of the ncf though.

From the log file, there are actually COL and ROW variables in the BELD5 file:

“ Number of landuse types in factor file: 259

ERROR: MISSING LAI FOR VEG TYPE: COL

ERROR: MISSING SLW FOR VEG TYPE: COL

ERROR: MISSING WINTER FAC FOR VEG TYPE: COL”

I will send you a script that should strip them out.

1 Like

This worked for me, and BEIS 3.7 is running for my 1.3km grid. Thanks for helping me!