SMOKE v4.7 installation problem

Hello everybody,

I am new to SMOKE. So, I downloaded lates version of SMOKE (which is SMOKE v4.7 - intel/18.0.2) from, then install it.

I am not sure if it is pre-compiled SMOKE or not. However, once I run the this command (source ASSIGNS.nctox.cmaq.cb05_soa.us12-nc), I have received this error:

-bash: setenv: command not found

I dont know what I should do. Can anyone help me in this regard?

SMOKE requires the tcsh or csh shell, and you are using the bash shell.
For most of the tools available on the CMAS Forum, you will need the tcsh or csh shell.
You can determine your shell using the following command.
echo $SHELL
If you have a system administrator, you can ask for them to change your default login shell to tcsh, or you can interactively using the command
If you will be using these tools often, it is probably better to ask for your login shell to be changed by your system administrator.

Here is a link that contains information about shells.

Thank you so much for your quick response.

I took a screenshot. Once I run source ASSIGNS.nctox.cmaq.cb05_soa.us12-nc command in the current work environment, I received this error:

Then, I tried to change bash shell to csh shell and then run the above command. Here is the screenshot:

I am confused what is wrong.

at this point, nothing is wrong. setenv AUTO_DELETE ON (which most people do) would then control how the system cleans up after itself.

In the next step of installation of SMOKE v4.7, the manual says below, however, I am not able to find my *.cshrc file. Anyone can help me?


Go to your home directory, then use a text editor to view the .cshrc file (note that this file is a hidden file, which can be listed in UNIX using the ls -a command at the prompt).

In the .cshrc file, add the following line:
setenv SMK_HOME (your selected directory for SMOKE installation)


Your .cshrc file will be located in your home directory.
To change directory to your home directory on a linux system use the following command:

cd ~ 

Then use the ls command to list the file that matches.

ls -rlt .cshrc

To view what is in the .cshrc you can use the more command

more .cshrc

You can use vi or gedit to edit the .cshrc file, if those editors are available on your system.


I follow the instruction to install SMOKE. The use manual says:

You should now be ready to compile the SMOKE programs. Change directories to $SMKROOT/src/.
• At the UNIX prompt, type:

Once I type “make”, I encounter with the following errors. Can anyone help?

Hi Monek,
In that section of the SMOKE user manual, section 12.4 is the following statement:

Unless you are planning to modify the SMOKE source codes, DO NOT try to compile the codes; use the precompiled binary Linux executables provided by the CMAS Center.

If you need assistance learning how to use the linux environment and SMOKE modeling system, we have an online SMOKE training class that may be helpful for you to take.

This will not teach you how to compile SMOKE, only to learn how to use the scripts and analyze the output.

It may be that you do not have I/O API properly installed and specified in the Makefile, and that is causing your compile error.