SMOKE version 4.6 Public Release


#1

Dear m3users,

The Community Modeling and Analysis System (CMAS) center at the UNC Institute for the Environment, in cooperation with the U.S. EPA, is pleased to announce the release of SMOKE version 4.6. The SMOKE v4.6 release includes various enhancements and bug fixes, including new SMOKE Digital Object Identifier (DOI) for your SMOKE reference and the complete SMOKE4AERMOD run script package as well as the user’s documents to generate AERMOD-ready “helper" input files for AERMOD model run in chi/q mode.

Documentation, downloads, source code, and detail release notes for SMOKE v4.6 can be accessed through www.cmascenter.org or SMOKE github release.

Please report any bugs or problems with this release to the CMAS help desk.

Best regards,

B.H. Baek, Ph.D.

SMOKE Model Developer

Research Assistant Professor

Institute for the Environment / CMAS

University of North Carolina at Chapel Hill

www.smoke-model.org


#2

Thanks for the announcement. I could not find the new v4.6 download on CMAS website though:


#3

The current version of download will not appeard on the download dropdown option since it is a current version. You can click the button “Download” on the main page to download the latest version.


#4

Dear Baek,

I am new to Linux and SMOKE. I have installed SMOKEv4.6 successfully. When I run the test case, source ASSIGN file is successful, but run smk_area_nctox.csh and the following files failed. The terminal says ‘Please verify that both the operating system and the processor support Intel® F16C, FMA and BMI instructions’.

I used SMOKEv4.0 and v4.5. There is no such error in v4.0 and 4.5 when I ran test case.

Do you know how to fix it? Thanks!


#5

SMOKE v4.6 is compiled on the latest Linux OS. Sound like your Linux OS is older than our new OS. There hasn’t been any significant updates made to SMOKE v4.6 compared to v4.5. I think you should use the SMOKEv4.5 for your modeling runs.
If you have to use the latest v4.6, then you need to compile the SMOKE codes on your machine instead of using the precompiled executables that come with the package.


#6

Thanks for your information! The purpose I would like to use v4.6 instead of the former version is that I tried to use EDGAR data. But when I run smk_edgar_HEMI108k.csh, grdmat failed.

Can the problem be solved when I use the latest version? If not, do you have any idea how to fix it? Thanks again!


#7

I am not sure what kind of error but yes, I fixed a bug in Grdmat to process EDGAR last year. Not sure whether that is the same bug you are facing or not. If that is the case, you probably need to compile the SMOKE v4.6 on your server with the latest IOAPI 3.2.