USGS landuse not supported?

Hi
I was trying using USGS landuse (has 28 categories, as obtained from WRF) with CMAQ5.3.1 but the model is not running perhaps it does not take USGS land use? Here is the error:

 *** ERROR ABORT in subroutine Init_LSM on PE 000
 Land use scheme not supported

PM3EXIT: date&time specified as 0
Date&time specified as 0

What land-use types (used in WRF) are supported in CMAQ? How to make the data with USGS 28 land categories work with CMAQ run?

Thanks

I have to admit that I am not familiar with a 28 category USGS land use scheme.

As far as I know, CMAQ can use the following land use schemes: NLCD40 (40 categories), NLCD50 (50 categories), USGS24 (24 categories), and MODIFIED_IGBP_MODIS (20 categories).

You can obtain the land-use scheme used in your WRF fields by looking at the header (via ncdump -h) of your MCIP files, specifically the string “LAND USE CLASSIFICATION:” What does that string show in your files?

Thank you for the reply. The string says ‘USGS’

LAND USE CLASSIFICATION: USGS

This is outside my area of expertise, maybe someone with more WRF background can chime in. Are there multiple USGS options in WRF, a 24 category option and a 28 category option?

What CMAQ is looking for specifically is the 24 category option. In centralized_io_module.F, the MCIP “LAND USE CLASSIFICATION” string is parsed and the following schemes are recognized: “USGS24”, “NLCD40”, “NLCD50”, and “MODIS”.

Which version of MCIP are you using? If you are using the latest version, how many “layers” do you see in your LUFRAC file? If you are using an older version, how many LUFRAC_## variables are you seeing in your GRIDCRO2D file?

WRF seems to have 28 categories if used usgs_lakes landuse, which is the case with mine.
I am using version 5.1 mcip (cmaq 5.3.1), and LUFRAC has 28 layers. I also tried to mix LUFRAC files from nlcd and other files from usgs28, the model still complained about landuse scheme. It seems like the attribute string about LAND USE CLASSIFICATION is more important than what is inside the files.

Thanks. The answer then very likely is that the usgs_lakes option in WRF is not supported by CMAQ because it is distinctly different from the standard 24 category WRF usgs option which is supported by CMAQ. However, to confirm my statement, I will also flag this to a colleague who knows much more about this than I do. Just a heads up that this colleague is taking time off this week so you may have wait a little bit for the answer.

I would strongly advise against mixing LUFRAC MCIP files generated from an NLCD40 WRF run with MET* and GRID* MCIP files generated from a usgs_lakes WRF run. Even if CMAQ would let it pass, you’d create complete inconsistencies between the land-surface fluxes in your WRF simulations which influenced the meteorological fields and the dry deposition calculations in CMAQ.

Okay, thank you, for the suggestions.

I did this for my own runs, but did not get around to putting these modifications into the CMAQ release. I had to modify PHOTOLYSIS_ALBEDO.F and LSM_MOD.F, but it was quite straightforward.
Contact me by email and I can walk you through it. We should get this into the release version of the model anyway. What version of WRF are you using?

Thank you. The WRF version I am using is 4.2. I just rerun wrf with 24 categories landuse, and hopefully that will be okay for CMAQ, and if not, I will contact you via email. However, CMAQ seems extremely slow (seems almost impossible) when using more frequent inputs (now at 15 minutes interval vs previous runs with hourly inputs). Do you have any recommendations on this regard? I used the same number of cores in both cases; the run using hourly input data finished quite quickly (in about 7-8 hours for total of 48 hours simulation) but the one using input files having 15 minutes interval is just stuck at about 1 hour simulation time in run time of 7-8 hours!

Thank you.

Are you using profile boundary conditions?
You may be experiencing the same issue as described here.

If not, please post a new thread.

Yes, I was using profile BC. The hemispherical averaged conc files provided by CMAS unfortunately do not go beyond 100 hPa and so to get to 50 hPa I used profile boundary condition. Perhaps I need to rerun WRF with ptop going only up to 100 hPa!

Thank you

Could you please verify which H-CMAQ concentration files you obtained that have a model top of 100 hPa?

The file with quarterly average H-CMAQ output posted in this folder extends to 50 mb.

Thank you very much! For some reason, I happened to encounter an error (some previous filew left undeleted) while trying to run icon/bcon with quarterly averaged file but turns out that this file indeed goes up to 50hPa! Thank you