ConfigFile ignored

Hi there,

I found that the -ConfigFile option was ignored when Verdi 2.1.4 was launched in linux command mode. My configure file could only be imported on GUI. Has anyone else ever experienced the glitch, or have I missed out something?


Hi Roger,

I tested and confirmed that this option works using the example script available in the VERDI software.
cd /[your_path]/VERDI_2.1.4/data/scripts
chmod 755 verdi_script_tile_with_config.csh

It produces an image that uses the following config file:
-configFile $cwd/data/configs/o3_10bin.cfg \

If you re-run the script after removing the -configFile line, then it generates the default color map.

VERDI is case sensitive when running the command line options, so be sure you are using


The other thing to check is that the path to your config file is working.
For the example script, you would need to verify that $cwd is defined.
echo $cwd and also that the config file exists.

Please let me know if you are able to solve your issue.

Hi Liz,

Thanks for your instructions. I later found out that the order of verdi arguments matters.

My run script previously put '-gtype tile ' before '-configFile $whatever ', so the effect is that a tile has been created before the script has any chance incorporating the config file. By swapping the configFile flag before the gtype, the tile is now with the desired color scale.


1 Like