VERDI and its problem with shapefiles from linux terminal

I’m trying to open a CMAQ output file (.nc) into VERDI (2.1.3) from terminal in Ubuntu which works perfectly fine. I am also able to add a shapefile to the command with the -mapName switch and VERDI opens both the data and shapefile.

./ -f $home/ -s “NO2[1]” -gtype tile -mapName $home/shape_file.shp

The problem is that VERDI does not show the shapefile on it’s correct location on the CMAQ data and it seems that the map is shifted down. Another strange thing is that if I add the same shapefile (manually) through the add GIS layer tab in VERDI, the map works just fine (that is, the map and its projection setting shouldn’t have any problem, and the problem just appears when I add it through the terminal command). The behavior is the same for other shapefiles too.
Can anyone help me in this?

Seems that VERDI (2.0_beta) does not load the shapefile from the terminal command at all.


Please try re-ordering the commands.

-gtype tile should be last.

./ -f $home/ -s “NO2[1]” -mapName $home/shape_file.shp -gtype tile

Hi @lizadams

Thanks for the quick reply. I did what you suggested and still have the same problem in both versions of VERDI.
I’m suspecting that VERDI supposes some variables for the projection system of the shapefile when it is called from terminal, while in the program, it reads the headers or other data or metadata. Can it be the case?

Do you have any other workaround in mind?

Many thanks.


Can you upload your files to a google drive, to aid in our testing and evaluation of this issue?

Thanks, Liz