ERROR ABORT in subroutine VPPM on PE 000

I am running CMAQv5.3.1 for 1x1 km domain for an area of 9x9 km2. The model is stopping on the first day itself with an error:

 *** ERROR ABORT in subroutine VPPM on PE 000
  max iterations exceeded in vppm at 77

PM3EXIT: date&time specified as 0
Date&time specified as 0

To resolve this i have tried to reduce the CTM_MAXSYNC from 720 to 360 to 150. With no luck in running the model.

I have tried to run the model in serial mode with same effect.

Please share some thoughts to resolve this issue.

Thanks and regards

Hi nimish,

This is just a suggestion. You can try reducing the value of variables DTNEW and DELT (multiply them by 0.5 or 0.) in zadvppmwrf.F right before CALL VPPM statements and see how the model behaves. Let me emphasize that this is not a fix but hopefully it will give us more clues why it crashed.


I have encountered the same issue, and have tried to reduce the CTM_MAXSYNC from 720 to 360/150/120/90, still got this error. But I found I use the wrong bcon files, after regenerate the new bcon, this error no longer occurs (“CTM_MAXSYNC” was still equal to 720). Hope this will give you some clues.

thanks a lot David and RoI. I was able to resolve the issue.

The model did run when i reduced the CTM_MAXSYNC to 3 sec but the resulting concentrations were quite low and my guess was that model was not taking into account the BC conc coming from parent domain. So I tried again by taking boundary condition from an intermediate grid. Initially I was trying to provide boundary conditions (BC) directly from 36x36 km file but later on i ran the model by first giving BC from parent grid to 4x4 grid and then from 4x4 to 1x1 km grid. The model ran without any hitch at CTM_MAXSYNC equal to 720.