Error while compiling run_cctm.csh

Hi all,
I’m trying to run cctm with the date from 20160424 to 20160504, with run_cctm.csh. I compiled mcip all of the dates, and compiled icon and bcon to 20160424. However, some messages happened, ls: cannot access * at my log files. I cannot find what is wrong for me. Please help.

Here is my run_cctm.csh file and cctm.log file.
run_cctm.csh (24.0 KB)

cctm.txt (31.6 KB)

Thank you.

Also I set environmental variable $OUTDIR to /home/dasol/CMAQ_v5.2.1/data/160424_160504/output_CCTM_v521_intel_160424_160504 ,
but it suddenly changed into /home/dasol/CMAQ_v5.2.1/data/160424_160504/160504/icon .

I wanted to know why, but I couldn’t. Please help.

Thank you.

There is an if, else, endif statement in the script that determines what directory the run script looks in to find the initial condition file.

You defined OUTDIR as follows:

 setenv OUTDIR  ${CMAQ_DATA}/${APPL}/output_CCTM_${RUNID} #> Output Directory

The ${CMAQ_DATA} environment variable is defined in the config_cmaq.csh script that is sourced at the top of the run script.

The ICpath or directory path is defined in the script as follows:

  set ICpath    = $CMAQ_DATA/$GRID_NAME/icon 

For the first time that the model runs, the definitions within the first part of the if clause take effect.

  if ($NEW_START == true  || $NEW_START == TRUE ) then
  setenv ICFILE ICON_v52_160424_160504_profile

Note, there was no definition for ICpath, so it uses the definition set earlier in the run script.

One option is to reset this ICpath definition to be the same as the definition of your $OUTDIR if that is where you placed the initial condition file.

set ICpath    = $CMAQ_DATA/$GRID_NAME/

The second day of the model run, the else portion of the if-else-endif clause will be used.

  #> Initial conditions
  if ($NEW_START == true || $NEW_START == TRUE ) then
     setenv ICFILE ICON_v52_160424_160504_profile
     setenv INITIAL_RUN Y #related to restart soil information file
     rm -rf $LOGDIR/CTM_LOG*${RUNID}*  # Remove all Log Files Since this is a new start
     #mkdir -p $OUTDIR
     set ICpath = $OUTDIR
     setenv INITIAL_RUN N

Thank you for your reply.
I changed the directory names, but it still doesn’t work.

What should I do now…
Please help…

cctm.txt (46.4 KB)
run_cctm.csh (23.9 KB)

Thank you.

Perhaps there is a setting for $OUTDIR in your shell environment that is overriding the setting in the runscript? Please also look for the definition of $OUTDIR in your config_cmaq.csh

echo $OUTDIR

If this environment variable is set, then use the following command to unset it.

unsetenv OUTDIR

Or, it may be set in your ~/.cshrc file.

grep OUTDIR ~/.cshrc

If that is the case, you will need to edit it, and remove the definition.

Thank you, I rebooted my computer and recompiled, then I could fix the error.

However, cctm still doesn’t work. It still cannot make CTM_* files.

What should I do now?

Please help.

run_cctm.csh (23.9 KB)

cctm.txt (37.9 KB)

Thank you.