Fail to read emission file

Dear all,

I’m using python netCDF4 to prepare CMAQ emission files, but the model couldn’t read.
So I tried Matlab and I got the same error, too.Here is the error message:

 netCDF error number  -49  processing file "GR_EMIS_001"
 NetCDF: Variable not found

 *** ERROR ABORT in subroutine gridded_files_se on PE 001
 Could not open GR_EMIS_001                      file

PM3EXIT: date&time specified as 0
Date&time specified as 0

Does anyone know how to fix this?


CTM_LOG_001.v533_intel_d02_20210727.txt (8.3 KB)
emis.txt (5.4 KB)

From the I/O API home page or

The Models-3 I/O API is A programming interface, not a data format !!
I/O API files are not synonymous with “netCDF files” !!

and treating it as a data format is NOT SUPPORTED: you don’t know the internal data structures used to protect the integrity of the data and you clearly got it wrong.

By analogy, do you attempt to write MS-Word documents with a hex editor? You don’t know the internal data structures there, either.

1 Like

Thank you @cjcoats !

After your reply, I used python to create my CMAQ emission files according to GRIDDED IOAPI Files format and it worked!
IOAPI/NetCDF restrictions link is below:


1 Like