HDF4 make check error

Hi all,

I am trying to run Spatial-Allocator to produce BELD4 files to use in SMOKE Normbeis3. I downloaded all of the NLCD and MODIS input files. When I run the landuseTool_WRFCMAQ_BELD4.csh tool (modified for my inputs and outputs), the MCD12Q1 files cannot be read because of an HDF4 error (there is no more detail than HDF4 error).

I am now trying to re-install hdf-4.2.11 in $SA_HOME/src/libs/. I installed the dependencies (jpeg-9c and zlib-1.2.11). I am able to configure (using the command “./configure --with-zlib=/central/groups/seinfeldgroup/Spatial-Allocator/src/libs/zlib-1.2.11 --with-jpeg=/central/groups/seinfeldgroup/Spatial-Allocator/src/libs/jpeg-9c --prefix=/central/groups/seinfeldgroup/Spatial-Allocator/src/libs/hdf-4.2.11/local --disable-netcdf --disable-fortran”) and “make” it, but it freezes on “make check >& check.out”.

I’ve attached the check.out file. The test it never seems to be able to complete is hdfnctest. I’ve tried using hdf-4.2.11 and hdf-4.2.13, and both have the same issue. Does anyone know what could be causing this?

Thank you,
Elyse

check.out.txt (9.5 KB)

Not sure if this will help because I get other unknown errors with hdf4 when running the ./landuseTool_WRFCMAQ_BELD4.csh, but I am able to install hdf4 with no errors.

For the third party requirements I installed them with:

sudo apt-get install libjpeg-dev
sudo apt install zlib1g

Then I configured hdf using the instructions from the README file:

make clean
rm -rf ./local

./configure --prefix=~/Spatial_Allocator/src/libs/hdf-4.2.11/local --disable-netcdf --disable-fortran

make
make check >& check.out
make install

Thanks for your response. I ended up having the admin of my server install HDF4, but now I get a generic ‘HDF4 error’ when I run landuseTool_WRFCMAQ_BELD4.csh and it tries to read the MODIS files. Maybe this is the same error you’re getting? I see that you posted in another thread I’m on as well; hopefully this issue can be resolved there.